Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently my office has been having some problems with our network printer.

Four computers and the printer are connected to a switch. All four of them can print documents. There is no router or internet connection.

However, two of the computers often take a very long time to send the information to be printed to the printer. Sometimes they can't even detect the printer giving error messages, and many, many minutes later the printer will print the document.

The other two computers seem to be able to print almost straight away all the time. We installed the printer drivers the same way on all the machines. That is by inserting the CD, letting the computer detect the printer, and then clicking continue until it's done.

Checking the printer network settings (from the printer menu) shows the following (if it helps):

  • IP address 169.254.179.195

  • Subnet 255.255.255.0

  • Gateway 169.254.179.195

What is the most likely cause for the error?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

If there's no server or router or Internet connection, it should be fine to leave your network using IPv4 link-local addressing (self-assigned 169.254.x.x addresses).

I'm guessing you're having speed problems from two machines because of basic Ethernet problems. Maybe the cables runs from those offices to the switch are too long. Or maybe the RJ-45 plugs weren't crimped onto the cables correctly. I'd try swapping the cable/port that one of the "slow printing" computers is connected to, with the cable/port one of the "fast printing" computers is connecting to, to see if the problem follows the machine, or follows the cable and port.

If the problem follows the machine, I'd look at the Ethernet speed and duplex settings for that machine, and make sure you don't have a speed/duplex mismatch between that machine and the switch.

You might discover something silly, like maybe the two "fast printing" computers and the printer only have 10/100 Ethernet cards in them, but the "slow printing" computers have 10/100/1000 cards, and maybe your switch is too cheap and isn't handling flow control well, so it's dropping lots of packets from the two Gigabit Ethernet machines, but the traffic from the two 10/100 machines doesn't overload the printer port, so that traffic doesn't get dropped.

share|improve this answer
add comment

Printer's IP address is link-local address that is assigned by default if there is no DHCP server in network. The printer and computers have to be in the same subnet in your case. You should check one of the computer's network settings and assign it to the printer but don't forget to change the IP address. E.g:

If computer's setting is something like this:

IP: 192.168.1.5 Subnet Mask: 255.255.255.0 (no default gateway if there is no router)

then your printer's should be like this:

IP: 192.168.1.(something other then the PCs) Subnet Mask: 255.255.255.0

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.