Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I open a lot of separate windows of Chrome on my Mac. However, juggling between two separate windows of Chrome doesn't work with Command+tab. When I press command+tab, only one instance of Chrome can be seen although there are many others in the dock.

share|improve this question
add comment

5 Answers

Applications on Mac OS X are generally only started once, and multiple windows belong to the same process. Internally, there can be additional processes (like for Chrome, or even Safari now), but there is one process responsible for the UI (e.g. the single Dock icon). Workarounds exist, but they are not well known, easy to use, and unreliable.

By clicking a Dock icon or selecting an entry in the application switcher (Cmd-Tab), you focus that application and all its windows.

To switch to a different window of an application, you can press the keyboard shortcut configured in System Preferences » Keyboard » Keyboard Shortcuts » Keyboard & Text Input:

enter image description here

To go in the reverse direction, additionally press Shift.


Another solution for switching between applications and/or windows is Exposé, now in Lion part of Mission Control. You can configure shortcuts for viewing all applications' windows or the current application's windows in *System Preferences » Mission Control:

enter image description here

When invoking the Application windows hotkey (or using the trackpad gesture configured in System Preferences » Trackpad » More Gestures » App Exposé, it presents the application windows side by side, with minimized windows shown smaller below:

enter image description here


There are also third party applications that make window switching easier for users coming from other operating systems, like Witch.

share|improve this answer
2  
⌘-` (command-backquote) used to work for me in Chrome, and still does in other applications like Terminal. But for some reason, in the latest version of chrome, I have to press ^⌘` (command-ctrl-backquote). Very annoying, as I use this function in both Chrome and Terminal, and it is impossible (that is, impractically difficult) to make a single key combo that works in both. –  Jameson Quinn Dec 30 '12 at 19:31
    
Mavericks and chrome 33.0.1750.146 -- ⌘-` is not working. –  Aaron McMillin Mar 14 at 15:16
    
@AaronMcMillin Mavericks and Chrome Version 33.0.1750.149 -- ⌘-` is working. Did you check System Preferences to make sure this is the configured shortcut for this? –  Daniel Beck Mar 14 at 18:34
    
It is on in Preferences. Actually it doesn't work for Terminal.app either, but ⌘-Left and ⌘-Right do. –  Aaron McMillin Mar 14 at 20:36
    
@AaronMcMillin Are you pressing the wrong key? Depending on your keyboard layout, it could act as a regular key or a deadkey. If you press that key alone, then e, do you get è or `e? If the former, it's the wrong key (or keyboard layout). –  Daniel Beck Mar 14 at 21:09
show 1 more comment

Cmd + ` is the shortcut for juggling windows on Mac.

share|improve this answer
    
Still relevant today. –  sshakir 2 days ago
add comment

Mac apps generally only have one instance, even if they have many separate document windows open. To use the keyboard to switch between windows of the same app, use Command+` (backtick, above the tab key, at least on my US-Qwerty keyboard layout).

I'm not sure what to make of your comment that "there are many others in the dock". Did you make multiple copies of "Google Chrome.app" so you can launch multiple instances, and that's what you see in the dock? It's possible that although you have many copies of Chrome in the dock, maybe you've only actually launched a single instance. Or did you minimize some Chrome windows to the dock, and it's the minimized window icons that you see in the dock that you're thinking are separate instances of Chrome? I think it's probably this.

share|improve this answer
add comment

Swedish keyboard: cmd+<. This should also work for nearly every other application for OS X.

If you have another localisation you could try cmd+"left-bottom-most" key. Hopefully the location is the same.

share|improve this answer
add comment

Mavericks and Chrome AND an external keyboard:

need to use -\ key (to the left of the z) instead of -`

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.