Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am learning the VIM, I don't know what I type wrong, it shows me some strange char, how can I clear that??

enter image description here

enter image description here

share|improve this question
up vote 7 down vote accepted

You aren't typing wrong, vim is just informing you that there is no more text, or that some part of it does not fit to screen. You want to see these things.

The tildes ~ mean that those lines are after the end of the document; there is no more text. You cannot disable this indicator.

The at signs @ mean that those lines are part of a paragraph that would extend past the end of the screen. To disable them and make vim show as much of the line as possible, you can :set display+=lastline, but this might end up confusing later.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .