Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a stockpile of computer components from my workplace and I built a desktop PC. I have tried several cd-rom drives and even one from my other personal pc but when I have it attached to the slave end of the master cable along with my Hard drive my OS will not boot. It says no OS found.

I have tried reversing the cables master/slave ends and same thing happens. My BIOS is configured to allow booting from USB, disc drive, hard drive etc.. and I have tried disabling all but hard drive and it acts as though it must boot from cd-rom if cd-rom is plugged in. I have also tried waiting for the PC to boot up and then plug in the cd-rom when the PC is on and it obviously wont detect it.

I have tried 10 different master slave cables and 7 different cd-rom drives, I have about 20 PC's laying around and have fired up the BIOS on all of them, they are identical computers and they boot just fine with the same cable configuration i know its just one pc but I am determined to see this issue through.

share|improve this question
3  
did you check the jumper config? master/slave positions on the cable don't matter if the jumpers arn't set to cable select. –  Journeyman Geek Feb 15 '12 at 7:09
add comment

1 Answer

Adding to what Journeyman Geek said. It gets recommended (at times) to put the CD in as slave. It does sound like Joshua covered all the things, some drives/controllers will simply not work with a CableSelect method/setting. Some worked better using CS methods.

Some drives have "master" "slave" and a 3rd jumper setting "Master with slave" . Those drives caused me problems, because of the 3rd setting, when combining with the CD (because it is master expecting a slave to exist, testing alone vrses testing with a second item is different).

The jumper info was not always correct. Getting onto the hard drive manufactures site , and checking/comparing jumper config for that specific drive was important.

When trying to get it to boot to an OS, like a windows OS, there has to be an MBR for the system on it.
The boot files have to be there on the disk. The error you get is most common for the boot files, MBR not being set-up, or the disk not being in boot order, or not being seen.
I had one disk with a MBR problem that did not clear easily. I don't know enough about how all that works , but it was not a disk fail problem , although it acts like one. And the standard methods for resetting the MBR did not work.

You have an OS on it, but did not describe If you were putting it on, or moved it from somewhere, or if it is a working image ?

I would Back up a bit in a situation like this, and Insure that the cables and jumpers are correct, then Not boot into the disk operating system. I would try and observe the disk Via a different disk first. You did not describe using any "other" boot thing like boot CDs or Boot flash drive, or even floppy, to look at it from the outside.

Back even further in Diagnosis, when doing the PATA thing , the area of the BIOS that shows the existence of the hardware was useful. If it did not show up in the hard disk section, It was often some hardware issues I had not completed correct. Jumpers, cables, slot used.

Other notes: when it boots or your trying to get into it from another boot, being slow can be a cable issue, or a disk issue, , plus many other things, but those 2 would be more common.

if you need more information, add more information or testing info to your question?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.