Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Snow Leopard on my Macbook (Model identifier 2,1) is refusing to connect to the internet via the WiFi connection I use in the office - the very same network that my iPhone is happily connected to without problems. Its giving me the new "Alert: No Internet Connection" messgae, which Google searches suggest is becoming a menace to a lot of SL users.

I've tried the following so far :-

  • Restarting my Macbook
  • Toggling Airport on and off
  • Getting network settings to not remember that network
  • Changing the device priority order in network settings

Anyone else got any suggestions? Didn't have these problems in Leopard, contemplating a downgrade at this point, since its already caused me MySQL and PHP issues. Do Apple actually test things?

Update works fine on my home wireless, which would normally make me think its an issue with the office router, but if that were the case the iPhone wouldn't connect to it and it wouldn't have worked under Leopard.

Its worth mentioning that I don't have access to the settings of the office router nor can I reboot it. I'm looking for a fix at the Mac end of things

share|improve this question
2  
+1 for using the word "steadfastly" –  Matthew Ruston Sep 10 '09 at 13:20
1  
Also, resolutely, unerringly, unbendingly and indubitably refusing to connect, but I'd be risking a -1 for verbosity ;-) –  Rob Cowell Sep 10 '09 at 13:25
    
Does it connect to the wifi network but refuses to route traffic to the internet, or does it not even connect to the wifi network? IF it doesn't even connect to the wifi network, is the network visible as an option to connect to, or not even visible? –  Console Sep 11 '09 at 9:47
    
Console : the first option I believe, its self-assigned IP only. On a Linux box I'd just use dhclient to re-request from a command line but it doesn't seem to exist in OSX –  Rob Cowell Sep 11 '09 at 10:23

2 Answers 2

up vote 2 down vote accepted

You could try the update to 10.6.1. There is no mention of fixes to wireless but I think I read somewhere that minor networking updates were made.

share|improve this answer
    
Ah yes, forgot that came out last night. May be some delay testing this, due to the old "need internet connection to fix internet connection" conundrum.... –  Rob Cowell Sep 11 '09 at 10:22
    
That's nailed it, thanks Alex. –  Rob Cowell Sep 11 '09 at 10:36

I've been having a strange issue at the last two hotels I'm staying at where I can connect to the hotel's wireless, but rather than taking me to a login, it just says "Alert: no internet connection" and I can't do anything.

I finally solved this problem by going into systems preferences, clicking on advanced, selecting TCP/IP, and then reselecting Using DHCP for Configure IPv4 and re-selecting "Automatically" Configure IPv6. This brought numbers for IPv4 Address, a Subnet Mask, and Router.

Got the idea to try this after scrolling through some of the ideas in the AirPort not working under Snow Leopard topic on Apple's discussion forum

Here is a link to my post: http://discussions.apple.com/message.jspa?messageID=10872475#10872475

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.