Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Seen on a PC running Fedora16

javaws -verbose jviewer.jnlp

Runs the applet ok when started from the root account. Fails with FailedDownloadException when started from a normal user's account. tcpdump shows that no TCP packet is sent out in the second case. My network has no proxy requirement. The command's output looks the same, from root or not. Here it is:

% javaws -verbose jviewer.jnlp
Java(TM) Web Start 10.0.0.8-fcs Launching: /usr/java/jre1.7.0_01/bin/java /usr/java/jre1.7.0_01/bin/java
    -classpath  /usr/java/jre1.7.0_01/lib/deploy.jar 
    -Djava.security.policy=file:/usr/java/jre1.7.0_01/lib/security/javaws.policy
    -DtrustProxy=true
    -Xverify:remote
    -Djnlpx.home=/usr/java/jre1.7.0_01/bin
    -Dsun.awt.warmup=true
    -Djnlpx.origFilenameArg=jviewer.jnlp
    -Djnlpx.remove=true
    -Xbootclasspath/a:/usr/java/jre1.7.0_01/lib/javaws.jar:/usr/java/jre1.7.0_01/lib/deploy.jar:/usr/java/jre1.7.0_01/lib/plugin.jar
    -Djnlpx.splashport=37732
    -Djnlpx.jvm=/usr/java/jre1.7.0_01/bin/java
    com.sun.javaws.Main
    -verbose
    /tmp/javawg9rK2Q
share|improve this question
1  
What information is contained in the FailedDownloadException? –  Oliver Salzburg Feb 15 '12 at 12:46
    
Thanks, but don't worry: I just found that javaws was trying to use a proxy whereas it was not supposed to do so. –  G.Bayle Feb 16 '12 at 10:21

1 Answer 1

up vote 0 down vote accepted

Javaws does not understand Firefox "no proxy" exceptions written in the form ip/mask (jre1.7.0_01, Firefox 10.0) It worked for root because Firefox used no proxy at all. My user account uses a proxy, so I had javaws work there by adding the full IP address into Firefox's "no proxy" exceptions setting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.