Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an issue with Ubuntu 11.10 automounting USB HDDs where the permissions for all files on the mounted volume are set to -rw-r--r-- and I can't change them with chmod.

I don't have the same issue automounting under Mint, all permissions come up as -rwxr-xr-x

which is what I want.

running mount -l from the terminal reveals that the only difference between the Ubuntu and Mint USB HDD mounts is showexec

So I think this is where the issue lies. I have no idea how to modify what Ubuntu does when automounting USB drives, but if I could somehow get it to include the showexec command line option then maybe this would fix the problem?

Possibly a modification to /etc/fstab?

Any pointers gratefully received.

share|improve this question
1  
Seems like this answer indirectly covers what you need: askubuntu.com/a/24409/34265 –  Oliver Salzburg Feb 15 '12 at 13:08
    
It seems odd that there isn't a simple defacto means of controlling the auto mount options in ubuntu - all I've found are hacks. Some even suggest modifying and recompiling the kernel - seems crazy! All I want is for Ubuntu not to apply the showexec option when performing an auto mount. The fstab route seems popular but its not really what I want to do which is change the generic auto mount process –  bph Feb 15 '12 at 13:21
    
The kernel can stay. You might, however, have to patch/recompile "udisks", since it has the default options hardcoded. (It might be that Mint packagers did just that.) –  grawity Feb 15 '12 at 14:28
    
the mint distro just has a different fmask hard-coded (which happens to suit my needs) –  bph Feb 15 '12 at 15:10
    
i've worked around by just writing a script to unmount the auto mount then remount it manually specifying a suitable fmask. I still think changing the automount options is an obvious thing to want to do with no easy way of doing it? –  bph Feb 15 '12 at 15:12
show 3 more comments

1 Answer

up vote 1 down vote accepted

You are correct when suggesting on your question the use of /etc/fstab to auto mount a USB HDD device.

You haven't provided your USB HDD device specifications, its location or the desirable mounting point, but, here's an example:

/dev/sdb1 /media/Test ntfs-3g defaults,user,exec,uid=1000,gid=100,umask=000 0 0

With this configuration added to my /etc/fstab file, I've mounted the device having all privileges over its files. So, every time my system boots, Ubuntu will auto mount the device, or issue a warning if the device isn't found.

  • Replace /dev/sdb1 with your device location:

    To find out your USB HDD device location, you can use at your terminal:

    sudo blkid
    
  • Replace /media/Test with your target directory:

    The target directory must exist, create it beforehand, using the terminal:

    mkdir /media/Test
    
  • Replace ntfs-3g with your USB HDD device file system:

    Refer to the Fstab :: File System Type for further specifications.


Related reading: Fstab - Community Ubuntu Documentation

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.