Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Acer ZG5 netbook. After 1 year of using Ubuntu, I installed Windows 7 on it. Additionally, I installed a BIOS update that was supposed to fix battery issues. However, it restarted and would fall into a loop of restarting once it hit the Windows login as if it never actually flashed the BIOS.

Then I proceeded to do a BIOS restore per the instructions found here in which one copies the image unto a USB and tries to reset the BIOS by starting with Fn+Esc pressed.
At this point I did this with the correct BIOS (I double checked), but since this point, my computer never started again.
I tried to reset the BIOS again but it would not read from the USB. I even tried it with a USB floppy to no avail.

So right now I have a computer whose components work, but which only shows a blank screen when turned on but does nothing.

Does anybody have any idea what to do? Or maybe even any ideas as to what to do with the components?

share|improve this question
    
You would have to take the battery ( on the motherboard ) and research on the Acer website how to reset the bios. You might want to break down and take it somebody with the correct tools and skill set, because it involves disconnecting a bunch of stuff. –  Ramhound Feb 15 '12 at 14:48
    
I should have added that I have also done that. I have taken the battery out of the motherboard but that did not work. I have experience opening laptops up so I gave that a shot but that did not work either –  avivas Feb 15 '12 at 19:23
    
See superuser.com/questions/29221/… - possible, but quite a technical procedure. –  pjc50 Feb 16 '12 at 13:38

3 Answers 3

The Acer Aspire One has a built-in BIOS recovery routine, which can boot into a minimal BIOS environment via a special boot block to re-flash the BIOS, even if the system does not pass POST and does otherwise not boot anymore. This procedure is also known as Crisis Disk.

First format an USB flash drive with FAT. It does not need to be bootable.

Download the latest BIOS, and extract all files. Put both FLASHIT.EXE and the BIOS file with FD suffix in the root directory of the flash drive. The files must not be in a folder. Rename the BIOS file to ZG5IA32.FD before proceeding. It only works with this exact filename.

Turn the AA1 off, and verify both battery and AC adapter are plugged in.

Press Fn and Esc simultaneously, keep them pressed and press the power button. Release Fn+Esc after a few seconds. The power button starts blinking at this point. Press it once. The AA1 will now access the files on the flash drive and initiate flashing the BIOS. After a while the power button stops blinking, and the AA1 reboots by itself. Wait patiently.

If it doesn't reboot, but keeps blinking, wait at least a few minutes before turning it off, and try again.

Source of Information

.

share|improve this answer
    
I have already tried this as expressed in the question (see the link), the USB never reads and I have even left it on for a whole night and in the morning the light simply continues to blink. Any ideas? –  avivas Feb 15 '12 at 19:25
    
Did you try all the usb ports? –  Moab Feb 15 '12 at 21:53
    
yes I did try every single USB port, different USB Drives (all formatted in FAT), I even tried different formatting as well as a USB Floppy on every single port –  avivas Feb 16 '12 at 3:59
    
" The power button starts blinking at this point. Press it once." did it blink after holding Fn+Esc? Did you press it once after it blinked? –  Moab Feb 16 '12 at 16:43
    
Yes, I would hold Fn+Esc, then it would blink, at that point I would press it again and it would continue blinking, the USB would never read and I could leave it for hours and it would just continue to blink –  avivas Feb 16 '12 at 17:19

I had the same issue with my friends similar model, when the 3310 version of the bios failed to flash it, I used the previous version and it worked just fine. the instructions are the same in both cases, perhaps you can try that if you still have that Aspire One.

share|improve this answer
    
Thanks for the tip - unfortunately I don't have the computer anymore just saved the HDD and the RAM. I can't believe I didn't try that before.... –  avivas Sep 12 '12 at 15:43

I have the same problem, and I tried another few USB sticks and lo and behold it worked. I didn't have to press the power button after it started to flash on/off post (Esc+Fn button combo).

Fat/Fat32 does not matter and the whole process took just under a minute. You could just copy the files on an existing stick on root just as long as it's the aforementioned filesystem format. The bootblock routine on the Acer scans the whole stick for the required files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.