Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wanted to connect my external DVD drive to my old laptop and boot from a CD. But my computer doesn't show the DVD drive in the boot menu.

After trying to change BIOS settings and finally restored them to defaults, it still does not work.

I can't even hear the DVD drive working until Windows XP or Ubuntu are loaded. After the OS loaded, it works like nothing is wrong. And the mysterious thing is, that this drive has worked on this laptop before. Never a problem.

New to that is maybe, that I borrowed some friend the laptop but she only used Windows XP to write some stuff, but I can't think of what she have done.

The DVD drive works well on other computers to boot from. Other USB drives work well on the laptop.

How can I fix this problem?

share|improve this question
    
So this DVD Drive has been used to boot this machine in the past? If not, you may be out of luck. Booting from USB, can be finicky. You say the drive works after the OS is loaded? But can't boot from the drive? Have you tried and alternative disc to boot from? I have seen a good Drive won't boot certain boot-able discs. –  TheSavo Feb 15 '12 at 19:04
    
This is my old laptop, i have always installed all OS on that machine over exactly this external dvd-drive and now it won't work. Of course, i tried another cd, which ran before, but my computer doesn't show me the drive to pick in boot menu, no matter what cd is inside. I tried other computers and every cd runs fine... After OS runs i can acces the drive but not at boot time. –  sewo Feb 15 '12 at 20:44

1 Answer 1

Double check the boot sequence settings in your BIOS setup. "CDROM" and "USB-CDROM" are often separate options, and plain "CDROM" will only use PATA and SATA. (applies to all optical disk drives)

I have the same settings for floppy disks, "FLOPPY" and "USB-FLOPPY". My external floppy disk drive is not bootable unless I tell the BIOS (or F12 boot menu) to use "USB-FLOPPY".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.