Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed Windows 7 recently and now I can't access (read, copy, delete) a lot of files.

When I try to open these files, I get the error that permission is denied (although I'm using administrator account).

When I inspect the file, owner is said to be Account Unknown(S-1-5-21-122...

I am able to change the owner of a file to my current account, but I still can't open it or copy it. Now it says that I don't have a permission from a current user (which makes no sense)

Some of the files are very important to me.

I booted Ubuntu Live and tried to access the files from there, but again "I had no permission".

In Ubuntu I used umask=0000, owner was root.root and it appeared that file was open to be read, executed and edited. But still, I couldn't neither read, nor copy the files.

Also, I tried using "Linux Reader" which was able to copy files but copied files were locked as well.

Does anybody has any ideas how I can solve this problem?

share|improve this question
    
What files are we talking about? How were they created? –  David Schwartz Feb 15 '12 at 17:46
    
mostly binary files (jpeg, dwg...). They were created in Windows XP. Also, in Windows Explorer, these files are listed in green color (I don't know what it means). They were "green" in XP as well, but there I could open them. –  user118564 Feb 15 '12 at 17:52
    
Also, I just noticed that "Linux Reader" says that "data is encrypted". –  user118564 Feb 15 '12 at 18:07
    
Oh, if you're using EFS, you're screwed unless you backed up the key or have access to the installation that has it. Hope you have a backup. –  David Schwartz Feb 15 '12 at 18:08
    
I don't have the key back up nor the instalation that has it. However, I do remember the username and password of user that created it. Could that help? –  user118564 Feb 15 '12 at 18:15

2 Answers 2

You need to make yourself the owner and then give the owner full access to the files. Right-click on them, then Properties -> Security -> Edit.

share|improve this answer

I ran into the same problems you describe when I mounted another Windows computer's disk image in my Windows 7 machine.

Changing a file's ownership to access it is an operation that I personally wouldn't do, as this operation will tamper with the file's underlying file system. One scenario here is you change file ownership, then later want to access the disk in your old system - suddenly you cannot access the file system in the old environment.

Do you have an account with Administrator privileges? Under Windows 7, even if your account has Administrator privileges, Windows Explorer cannot be run with Administrator privileges (c't Magazin has made some investigation into this issue in German).

My solution is:

To my observation, activating the Administrator account as described above won't assign a password to Administrator. Therefore protect the Administrator account as soon as possible in the account settings. Or follow http://support.microsoft.com/kb/149427 before activating the Administrator account.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.