Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop with Windows 7 x64 and a Sound Blaster X-Fi Surround 5.1 Pro. I connect the HDMI output of the notebook to my LCD-TV and the external soundcard to my home-theater receiver through an optical audio cable (S/PDIF).

I have no problems viewing .mkv videos with 6 channels DTS or Dolby Digital. But this file is a .mp4 with AAC 6 Channels.

The problem is that I only get 2 channels/stereo in my receiver (it shows PCM 48 and only left and right speakers are shown in the display). When I get the 6 channels, all the speakers are shown in the display and also it says DTS or Dolby Digital.

Any idea how to make it work? I don't mind installing another player or other external codec to make it work.

Here's the MediaInfo shown by MPC-HC.

Format                           : MPEG-4
Format profile                   : Base Media
Codec ID                         : isom
File size                        : 2.00 GiB
Duration                         : 2h 5mn
Overall bit rate                 : 2 278 Kbps
Encoded date                     : UTC 2010-01-23 21:34:19
Tagged date                      : UTC 2010-01-23 21:34:19
Writing application              : Yamb 2.1.0.0 [http://yamb.unite-video.com]

Video
ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : [email protected]
Format settings, CABAC           : Yes
Format settings, ReFrames        : 4 frames
Codec ID                         : avc1
Codec ID/Info                    : Advanced Video Coding
Duration                         : 2h 5mn
Bit rate                         : 1 951 Kbps
Maximum bit rate                 : 9 358 Kbps
Width                            : 1 280 pixels
Height                           : 544 pixels
Display aspect ratio             : 2.35:1
Frame rate mode                  : Constant
Frame rate                       : 23.976 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.117
Stream size                      : 1.71 GiB (85%)
Writing library                  : x264 core 67 r1145bm d2e1e1c
Encoding settings                : cabac=1 / ref=4 / deblock=1:-3:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy_rd=0.0:0.0 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=2 / deadzone=21,11 / chroma_qp_offset=0 / threads=2 / thread_queue=2 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=1951 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Encoded date                     : UTC 2010-01-23 21:34:19
Tagged date                      : UTC 2010-01-23 21:37:59

Audio
ID                               : 2
Format                           : AAC
Format/Info                      : Advanced Audio Codec
Format profile                   : LC
Codec ID                         : 40
Duration                         : 2h 5mn
Bit rate mode                    : Variable
Bit rate                         : 327 Kbps
Maximum bit rate                 : 444 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Side: L R, LFE
Sampling rate                    : 48.0 KHz
Compression mode                 : Lossy
Stream size                      : 294 MiB (14%)
Encoded date                     : UTC 2010-01-23 21:37:12
Tagged date                      : UTC 2010-01-23 21:37:59
share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I ended up doing this:

Install ffdshow (32-bit), add ffdshow Audio Decoder to "External filters" of MPC HomeCinema, set it to "Prefer". Now ffdshow Audio Decoder will be used to decode whatever audio format it supports (e.g. AAC). In ffdshow Audio Decoder configuration > Output, make sure to check "AC3 (S/PDIF encode mode)".

I can elaborate if someone needs, just ask.

share|improve this answer
add comment

Following up on emzero's answer (don't have enough points to reply yet), you also have to make sure that AAC is disabled (unchecked) under MPC-HC's options > Internal Filters > Transform Filters. Otherwise, the external filters won't be activated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.