Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Foolishly, I installed Windows 7 with my new SSD set to IDE. I would like to change it to AHCI. I have done this before, with a different motherboard.

What happens:

  • I set the controller to AHCI in the BIOS; I also check correct boot order
  • On boot, I get the 'BOOTMGR not found' error
  • I use the Windows Recovery Console on the DVD
  • Diskpart etc can see the disks, and bootrec claims to have rewritten the MBR/bootloader
  • I reboot, same problem
  • Recovery Console again and it detects a problem, fixes, reboots
  • Recovery Console again and it detects the OS, and a problem - fixes, reboots
  • I ignore the 'press any key to boot from DVD' prompt
  • Windows boots fine
  • I restart without the DVD and I'm back to square one

That optional 'press a key to boot from DVD' stage is something that the recovery process introduces - normally you have to choose to boot to the DVD at the BIOS stage. You also see this when installing Windows. I suspect that whatever temporary state that is is compatible with AHCI - but not the standard it returns to.

I have done the msahci/iaStorV registry hacks to no avail (this worked with the previous board). I can put it back to IDE where normal service is resumed. The board is an Asus M5A99X, the southbridge is AMD SB950, and this is Windows 7 x64. I would quite like not to have to reinstall it again.

Any ideas as to what I can do as a permanent fix?

share|improve this question
1  
So changing the registry key in msahci doesn't work? I have NEVER seen this fail to function. –  Shinrai Feb 15 '12 at 21:36
    
Nope. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci and its value Start is set to 0. Same for iaStorV. There are other related keys like amdsata but I don't know what the state should be, so haven't changed them. –  Rob Pridham Feb 15 '12 at 21:38
1  
I would add this as the answer but I can't yet: I appear to have fixed this by performing the same type of registry fix to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\amdsata . O Bilal's post in this thread provides some clues. I don't know if this is an artifact of my driver installation order or just something that would have always happened, but hopefully it will help someone. –  Rob Pridham Feb 15 '12 at 21:54
    
+1 Nice find Rob –  Moab Feb 15 '12 at 22:02

1 Answer 1

up vote 0 down vote accepted

I appear to have fixed this by performing the same type of registry fix to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\amdsata

In which the value of Start must be set to 0.

O. Bilal's post in this thread provides some clues - others may find they need to do something similar for NVidia drivers, for example.

I don't know if this is an artifact of my driver installation order or just something that would have always happened, but hopefully it will help someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.