Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't understand why is not resolving on my computer. I have tried Google DNS and it still doesn't work. Neither does the DNS from my broadband provider. However, if I connect over a VPN it works. Why is this? Also, my phone has the same issue using WiFi, so it is definitely tied to my home network. How can I diagnose and fix this issue?

Edit: pics of in browser with and without vpn. Posted via VPN.

enter image description here

enter image description here

share|improve this question
Please edit and correct any errors on my part. I cleaned up your question, but may have made a couple of assumptions! – iglvzx Feb 16 '12 at 0:19
Very close. actually works. But any subdomain fails. I get the site for where the picture is suppose to be, but no pic. :( Some CSS script seems to be unreachable as well. This is an example of what I see: – Algific Feb 16 '12 at 0:29
Have you tried to empty your browser cache? Do you have any security add-on installed in your browser such as NoScript? – harrymc Mar 10 '12 at 8:47
What OS are you running on your computer? – Spiff Mar 12 '12 at 20:04
This is not a DNS issue since the domain resolves. I think the issue is in your router, since everything works just fine through the VPN tunnel. – goblinbox Mar 13 '12 at 22:12
up vote 1 down vote accepted

Your router has DNS caching issues. I had an older Linksys E1000 Wireless-N router, but I've found the issue also exists with other (cheaper) models.

Easiest thing is resetting your router, which usually cleans out the DNS cache. Check that your firmware is up-to-date, and update it if it's not. Another option is getting another router.

share|improve this answer
I'll look into it. By router do you mean the box with wifi antenna or the modem? – Algific Mar 14 '12 at 14:11
The box with the antenna. – Seabass Mar 14 '12 at 17:21's images generally come from, and their CSS and JS come from Both are aliases to *—the CDN (Content Distribution Network—like a competitor for Akamai).

You might want to look into whether or not you can resolve and/or connect to the * hosts that i.imgur and s.imgur resolve to, or see if there are other well-known sites that use EdgeCast and see if you have the same problem with those sites.

share|improve this answer
Liveleak has the same symptoms. – Algific Mar 16 '12 at 12:26

Can you perform an nslookup {whatever_subdomain} - and then try accessing those IPs directly from a browser - i.e. enter "http://123.456.789.012" in the browser.

It sounds like has banned you or blocked you (or the IP your DNS has given you) from some of their subdomains for some reason. You may have accessed the subdomains in question too much.

share|improve this answer

Open a command prompt and run "tracert" without the quotation marks. This will tell you where your packets are getting dropped, post the output.

share|improve this answer

Also, to get a more useful answer, try installing Firefox as an alternative browser and install Firebug as an add-on. It manifests itself as a "bug" icon. Visit its Network-tab and try loading the page again. Each element of the page will result in one line.

If you see your GET request for the CSS/JS files fail with Status 404, then the connected webserver could not find the requested URL. In your situation it likely means your browser was connected to an incorrect IP adress or the connection was intercepted (as in: transparent proxying by 3G providers or "clever" proxying routers) and incorrectly handled.

If it says "Aborted" in a line then an actual DNS resolving issue could be the reason. right-click the GET-part on the left and choose "Open in new Tab". This will yield a more informative error message because embedded resources usually fail silently, resulting in missing images or CSS/JS files as in your case.

Good luck.

share|improve this answer

This happens on windows, mac and on my android phone.

If this only happens when your phone is connected via the router, then the problem is maybe with the router.

If this also happens when your phone is connected directly to the Internet via the operator, then the problem is maybe with the website itself or that your ISP is victimizing it.

share|improve this answer
I think something is fishy with my ISP, because some other guy (just read online at random forum) is having the same problem as me! – Algific Mar 14 '12 at 14:10
I clarified my answer. But is the other guy and your phone connected via the same ISP? – harrymc Mar 14 '12 at 14:30

TL;DR: Set up your computer to ignore your router's DNS proxy and instead use another DNS server. Try your ISP's DNS server or use a public DNS server like Google's.

You're using a Mac. You can override your DNS server by:

  1. going to the Network control panel
  2. clicking Advanced…
  3. choosing DNS and entering the new server addresses, e.g. and

If you only want to use these DNS servers on your home network then create a new Location in the Network control panel.


I had a similar problem. For me, it was intermittent errors with * and also, ironically, with *, the site used to server Super User's static content. Lookups would fail for a while, then work for a while, then fail again.

I had recently upgraded my router, so it seemed to be something to do with that.

Using dig I tested queries against different DNS servers:

  • Queries to my router would fail intermittently. My router proxies my ISP's DNS servers.
  • Direct queries my ISP's DNS servers would fail intermittently too. Direct queries always worked with my last modem.
  • Direct queries to Google's Public DNS servers worked all the time.

So maybe my router was messing up DNS responses from ISPs servers (both proxied and direct). Or maybe the ISPs servers were failing intermittently? It was hard to tell, and I didn't bother working out which was the real problem. :)

The queries that were failing were for Content Delivery Networks. That makes sense, in a way, because CDNs often return complex DNS results to optimise performance.

Like me, you might have a problem with your router's DNS, with your ISP's DNS or with some interaction between the two. Here are possible solutions.

  1. Configure your devices to use another DNS server. Either use your ISPs DNS server directly or use a public DNS server such as the one Google provides.
  2. Edit the /etc/hosts file on your devices and manually add addresses for failing lookups.
  3. Set up your own DNS server internally.

Option 1 is the easiest. I recommend it if you're based in a location that has a local public DNS server. Here are the locations of Google's public DNS servers.

I'm in I'm in New Zealand, and I didn't want to go with a public DNS server in another country. Doing so would mean higher latency for me on every DNS lookup. It would also lessen one of the main benefits of CDNs. CDNs try to serve content from local servers if possible, and they do this based on the location of the DNS server. A US- or Asia-based DNS server would have lessened this benefit.

I also didn't want to want to use my ISP's DNS servers, since they were flaky when my router was involved, even for direct queries.

So option 2 was a bit better for me. It will mean a bit of maintenance, but I'm happy to use dig and edit /etc/hosts occasionally.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .