Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an issue with Ubuntu 11.10 automounting USB HDDs where the permissions for all files on the mounted volume are set to -rw-r--r-- and I can't change them with chmod.

I don't have the same issue automounting under Mint, all permissions come up as -rwxr-xr-x

which is what I want.

running mount -l from the terminal reveals that the only difference between the Ubuntu and Mint USB HDD mounts is showexec

So I think this is where the issue lies. I have no idea how to modify what Ubuntu does when automounting USB drives, but if I could somehow get it to include the `showexec' command line option then maybe this would fix the problem?

Possibly a modification to /etc/fstab?

Any pointers gratefully received.

share|improve this question

migrated from stackoverflow.com Feb 16 '12 at 2:58

This question came from our site for professional and enthusiast programmers.

    
have just signed up for a superuser account - is there a way of moving the question over? (or should I just cut and paste?) –  bph Feb 15 '12 at 12:57
1  
@Hiett There is a way. Flag it as off-topic. –  Oliver Salzburg Feb 15 '12 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.