Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i installed ghc and cabal on my centos 6 machine. both seem to be in working order.

but when I try to install yesod with cabal, i get this:

[root@localhost yesod]# cabal install yesod
Resolving dependencies...
cabal: cannot configure conduit-0.2.1. It requires base >=4.3 && <5
For the dependency on base >=4.3 && <5 there are these packages: base-4.3.0.0,
base-4.3.1.0, base-4.4.0.0, base-4.4.1.0 and base-4.5.0.0. However none of them are available.
base-4.3.0.0 was excluded because yesod-auth-0.8.1.1 requires base >=4 && <4.3
base-4.3.0.0 was excluded because yesod-core-0.10.1 requires base >=4 && <4.3
base-4.3.0.0 was excluded because yesod-0.10.1 requires base >=4 && <4.3
base-4.3.0.0 was excluded because of the top level dependency base -any
base-4.3.1.0 was excluded because yesod-auth-0.8.1.1 requires base >=4 && <4.3
base-4.3.1.0 was excluded because yesod-core-0.10.1 requires base >=4 && <4.3
base-4.3.1.0 was excluded because yesod-0.10.1 requires base >=4 && <4.3
base-4.3.1.0 was excluded because of the top level dependency base -any
base-4.4.0.0 was excluded because yesod-auth-0.8.1.1 requires base >=4 && <4.3
base-4.4.0.0 was excluded because yesod-core-0.10.1 requires base >=4 && <4.3
base-4.4.0.0 was excluded because yesod-0.10.1 requires base >=4 && <4.3
base-4.4.0.0 was excluded because of the top level dependency base -any
base-4.4.1.0 was excluded because yesod-auth-0.8.1.1 requires base >=4 && <4.3
base-4.4.1.0 was excluded because yesod-core-0.10.1 requires base >=4 && <4.3
base-4.4.1.0 was excluded because yesod-0.10.1 requires base >=4 && <4.3
base-4.4.1.0 was excluded because of the top level dependency base -any
base-4.5.0.0 was excluded because yesod-auth-0.8.1.1 requires base >=4 && <4.3
base-4.5.0.0 was excluded because yesod-core-0.10.1 requires base >=4 && <4.3
base-4.5.0.0 was excluded because yesod-0.10.1 requires base >=4 && <4.3
base-4.5.0.0 was excluded because of the top level dependency base -any

UPDATE: just tried installing haskell-platform to see if that would resolve what seem to be dependency issues but no luck. I get the same error when I run cabal install Cabal cabal-install yesod

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.