Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Debian Linux on a MacBook4,1 with the legendary Broadcom wireless chipset. Before updating the kernel to 3.2.0.1, following this guide to set up wireless worked like a charm.

However, after updating the kernel, when running m-a a-i broadcom-sta the following happens:

module assistant says "Bad luck, the kernel headers for the target kernel version could not be found and you did not specify other valid kernel headers to use."

A bit of info:

user@mac-debian:~$ lspci | grep Broadcom
02:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)

user@mac-debian:~$uname -r
3.2.0-1-amd64

Obviously:

root@mac-debian:/home/user# iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.

Any ideas to get som wireless up in this?

share|improve this question
    
Good luck with broadcom-sta, last time I tried to build it there was still some errors in broadcom-sta-source that wouldn't let it build, about a week ago. I was only able to get my wireless working by following this: linuxwireless.org/en/users/Drivers/b43 – Rob Feb 16 '12 at 19:00
up vote 1 down vote accepted

The Kernel headers must be earlier than the kernel you're running.
1) Check the /usr/src/ directory.

2) If corresponding headers (the same as your kernel version) are there, point the module assistant to them:
sudo module-assistant --kernel-dir /usr/src/your_kernel_version auto-install broadcom-sta

3) If not, install the corresponding headers package through apt:
sudo apt-get install linux-headers-$(uname -r)
Then, go back to step 2.

share|improve this answer
    
After installing via Synaptic PM (apt-get didn't work) I get the following error message from module assistant: "Warning, /usr/src/linux-headers-3.2.0-1-common seems to contain unconfigured kernel source (see manpage for details)!" – trolle3000 Feb 19 '12 at 21:26
    
Let's try to see if the kernel-headers are correct. Please, run the sudo m-a prepare command and then sudo m-a a-i broadcom-sta . If it doesn't work, it seems that we'll need to configure the kernel manually. – Temikus Feb 20 '12 at 7:26
    
thanks for your answer! As I'm presently in a pretty mission-critical time on the PC, I decided to revert to kernel 2.6.32-5-amd64 - it works. Your answer seems complete, so in the interest of closure: accepted. – trolle3000 Feb 20 '12 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .