Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an application that does not work properly under a standard XP user account, with missing buttons and such. It does work properly under an admin account. I exported the Admin current user registry settings for the application and then imported them into the standard user registry settings. It seems to work now, but I am afraid there might be unforseen repercussions of doing this. Is this ok to do? Ok to do with some things to keep in mind? Or should this not be done at all? I probably should have asked about doing this first, but too late now. I will uninstall the application, and reinstall it if need be.

share|improve this question

migrated from Feb 17 '12 at 1:20

This question came from our site for professional and enthusiast programmers.

Thanks. I meant to add a line at the bottom asking if there was a better SE site for this question, but I forgot. I flagged it to ask for a migration. – user1011625 Feb 16 '12 at 21:41
I take it that you installed the program using the admin account? – Synetech Feb 17 '12 at 2:42
Yes, it was installed using an admin account. – user1011625 Feb 17 '12 at 20:00
up vote 1 down vote accepted

That sort of registry manipulation is usually OK. There's no way to be certain that it won't cause problems, but since the application in question clearly already has problems I wouldn't worry about it too much.

One note: are you sure it was copying the registry data that resolved the problem? Is it possible that it was running it as an administrator that fixed it? That's a much more common scenario.

share|improve this answer
If the program was run as an administrator, then it would work correctly. I couldn't figure out how to have it always run as administrator without giving out the password. I was trying to figure out how to do that when I tried the registry trick just as an experiment. After copying the registry data it ran correctly without running as administrator. – user1011625 Feb 17 '12 at 20:05
The setup program may have created some necessary registry settings in HKEY_CURRENT_USER. That's a particularly dumb design, but not unheard of. If running it as a different administrator account doesn't work either, that is almost certainly the problem, and (if the end user can't install it himself) the only solution is to copy the registry settings as you've done. – Harry Johnston Feb 17 '12 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .