Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not very savvy when it comes to laptops. I have two identical laptops, old school Dell Latitude D410's. One works just fine, and the other does not boot at all. I have tried various things including, using the working battery pack and power adapter from the running computer. Swapped out the hard drive from the working computer to the non-booting laptop. Nothing seems to work. I really don't have a clue as to what it could be. But it does absolutely nothing. No attempt to boot, no sounds, no lights, etc. Any ideas?

share|improve this question
    
Most likely a dead mainboard, use it for parts. –  onxx Feb 17 '12 at 2:29
    
you'd want to try this trick with pressing the power button while the system is disconnected –  Journeyman Geek Feb 17 '12 at 2:41

1 Answer 1

up vote 1 down vote accepted

Not savy? Sounds like you tried all the right stuff and reported the critical info. Apparently you've attached a verified working battery and/or power supply and no lights were on. That's an indication that points to a bad motherboard. At that point in your testing, if you had a bad hard drive or memory or missing OS, you would have at least gotten the laptop's power LED to blink or one step better, beeps or blinking diagnositc leds. When you don't get any of those, with available power, then somethings wrong with the motherboard.

share|improve this answer
    
Thanks for the information. I suppose it will make a good parts laptop. –  syllable3 Feb 20 '12 at 22:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.