Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using QEMU 0.14.1 under Ubuntu 11.10 with kernel 3.0.0-17-generic, if I run qemu -cpu ? I get:

$ qemu -cpu ?
x86           [n270]
x86         [athlon]
x86       [pentium3]
x86       [pentium2]
x86        [pentium]
x86            [486]
x86        [coreduo]
x86          [kvm32]
x86         [qemu32]
x86          [kvm64]
x86       [core2duo]
x86         [phenom]
x86         [qemu64]
x86           [host]

...but when I run:

$ qemu -snapshot -m 256M -cpu x86 -hda live-usb.img 
Unable to find x86 CPU definition

I've tried x86, 486, x86-486 as well, with no success. So how do I actually use the CPU option?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted
qemu -M pc-0.14 -cpu core2duo -m 256 [-option argumentyouwant] live-usb.img

And x86 is cpu architecture is not an exact cpu... in cpu option u must use a cpu not architecture

share|improve this answer
    
Perhaps you could point him out why it wasn't working as well? –  Ivo Flipse Feb 17 '12 at 8:47
    
But -cpu 486 didn't work either. –  detly Feb 17 '12 at 17:48
    
Okay, it worked today... I must've made a typo when I tried it. Oh well, if it works it works! –  detly Feb 20 '12 at 3:15
add comment

You can use DOSBOX if you want a 486 computer with DOS, Or Virtualbox if you want a fast virtualisation.

share|improve this answer
    
Alas neither — I need to boot an existing live USB image using a 586 (or similar) architecture. Virtualbox might still be able to help with the latter I suppose, but I won't be able to check until Monday. –  detly Feb 18 '12 at 6:14
    
USB was generally absent in age of 586.... (There was USB 0.9 in FX mainboard, but that is no more considered USB) -cpu 486 works fine for me, i add -boot a/b/c/d to make it boot from "removable" device. Otherwise it uses -boot cad i.e looks for nonexistent CD and floppy first. –  ZaB Feb 18 '12 at 10:00
    
the embedded system I'm using is a 586 (or maybe a 686) architecture, and has several USB ports available (including BIOS support for USB booting). –  detly Feb 18 '12 at 11:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.