Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On other applications you just right-click the application shortcut, select properties, select the compatibility tab, and then select the option to run as administrator.

However, these options appear to be grayed out and unselectable on IE.

Thanks in advance.

share|improve this question
5  
This seems like a particularly bad idea. –  edusysadmin Feb 17 '12 at 15:55
    
As Sara rightly says, don't do this. Do you have a related problem you're trying to solve? –  John H Feb 17 '12 at 21:42

2 Answers 2

up vote 4 down vote accepted

Don't do this.

IE9 has taken many steps to be a more secure browser, and as such it shouldn't be run in Administrator mode, unless you're trying to resolve another particular problem.

If you look at the Compatibility Tab on the proper window it clearly states

Compatibility modes cannot be set on this program because it is part of this version of Windows.

So if you really wanted to change the Privilege Level you would have to circumvent some deeper in Windows.

You would be better off finding a work-around to the problem you think needs to be solved by always running in administrator mode.

share|improve this answer

I don't think you're looking in the right spot.

Go to the Shortcut tab and click the Advanced... button:

enter image description here

Then check the Run as administrator checkbox

enter image description here

You will still have to confirm the privilege elevation every time you use the shortcut.

share|improve this answer
2  
Only works when launching the shortcut, not every time though –  Canadian Luke Feb 17 '12 at 22:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.