Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Linux inside VMware in OSX.

I want to use gnome-do. The shortcut key to call it is super+space.

But that doesn't work when running inside VMware on OSX.

How can I enable to super key to function normally inside this virtual machine?

share|improve this question
    
How do you currently map your key? The Super key should be mapped to the Win key from Linux. So basically Win should suffice. –  slhck Feb 18 '12 at 12:04
    
The super key is the same. That's the problem. OSX will recognize it even when I'm trying to use it inside the VM. –  tony_sid Feb 18 '12 at 13:04
    
OSX will consume , you mean? Have you tried mapping e.g. Ctrl to Win? What do your current settings look like? –  slhck Feb 18 '12 at 13:11
    
Yes, that's what I mean. I'm using a windows keyboard, and the win key is the same as the super key in OSX. I haven't tried mapping ctrl to win, because then what would I use for ctrl? –  tony_sid Feb 19 '12 at 4:01
    
Ok, you nowhere mentioned that you used a Windows keyboard. Maybe add that detail to your question. –  slhck Feb 19 '12 at 10:03

1 Answer 1

VMware Fusion has an option to disable OS X related shortcuts (including e.g. Cmd-Space for changing the keyboard layout, or Spotlight) when in the VM:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.