Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was building a computer for my wife with an older SATA hard drive that I had lying around, and when attempting to do a new install of Windows 7 on it, the installer says:

"No drives were found. Click Load Driver to provide a mass storage driver for installation."

I ran the diskpart command: list volume, and it showed up as "Raw". So, I formatted it to NTFS and then it showed up as a healthy drive in diskpart. I also ran check disk on it with no errors. Windows 7 installer STILL can't find the drive. As far as BIOS settings, I have tried "Native IDE", AHCI, and Both AHCI/IDE mode (SATA slots 0-2 AHCI, 3-4 IDE). I tried all combinations... still "no drives were found".

At this point, I'm just scratching my head. Using the installation dos window, I can see and talk to the drive just fine, but the installer just doesn't see it at all. I've even written folders and files to the drive, and it still "can't be seen". Any help would be great.

Items of interest:

  • Motherboard model: Gigabyte GA-A75M-UD2H - BIOS Version F5 (latest)
  • Hard drive model: 80GB Seagate Barracuda 7200.7 ST380817AS (no other drives)
  • Installing Windows 7 using a FAT32 formatted USB Drive, which I've used for other installs
share|improve this question
did you clear the MBR? which will get re-written anyway, but you just did not indicate if you attempted that? – Psycogeek Feb 18 '12 at 2:47
Just for grins try install from a dvd. – Moab Feb 18 '12 at 3:05
@Psycogeek I just did now, by running bootrec /FixMbr. But it didn't seem to do anything to the hard drive in question. When I removed the USB installer drive, and tried the command again, it returned: "The system cannot find the path specified" – Albert Bori Feb 18 '12 at 3:17
@Moab I tried with an install DVD, same result. "No drives were found." – Albert Bori Feb 18 '12 at 4:01
Could there be another controller in the machine? I've had the Windows installer refuse to associate with the OS drive because it got lost looking at another controller for which it didn't have a driver. Pull the offending controller and it was happy. Windows itself had no problem with the extra controller, only the installer. – Loren Pechtel Dec 27 '14 at 12:26

Note that running these commands will break any previous OS and data on disk.

After you get past the language selection, select Repair, open Command Prompt and type the following commands (pressing Enter after each one):


list disk

select disk <number>


Restart the system, and now you should be able to complete the installation.

share|improve this answer
note that running these commands will break any previous OS and data on disk. – Amir Ali Akbari Jan 15 '13 at 10:14
What if no disk is listed there? – Akira Oct 1 '13 at 9:27
If no disk is listed, it hasn't been detected; this is likely drivers, or BIOS/UEFI configuration related. – Gui Apr 7 at 7:43

I would set bios to ahci, then load the AHCI driver during setup using the "load driver" button. It can be found on the gigabyte website under Sata Raid>AHCI > preinstall driver.

If that does not work try another hard drive, if it fails also then it is some sort of bios or motherboard bug. Try rolling the bios back to F4.

share|improve this answer
I loaded the AHCI drivers, same result. Just for kicks, I copied the drivers to the drive in question, and was able to get the installer TO INSTALL THE DRIVERS OFF OF THE DRIVE IT "CANNOT FIND" (caps for angry). I have tried this with multiple BIOS versions (started with F2). This mobo was working fine with a different (slightly newer) hard drive. – Albert Bori Feb 18 '12 at 5:10
@AlbertBori truely strange and frustrating. When i installed 7 first time only time, they told me if I first created the partition, it would not make that 100meg extra partition on the front of the disk. You have the thing formatted, files copy to it, the whole thing. I assume you also tried with the partition table tossed? – Psycogeek Feb 18 '12 at 6:37
@AlbertBori thats not how to do it, there is a "load drivers" button, load them from a flash drive or other removeable usb media. – Moab Feb 18 '12 at 19:07

Just somethings I'd would try if you haven't:

Leave AHCI on

1 - Make sure the SATA port your using is enabled in BIOS

2 - Try another SATA cable

3 - Try another SATA port(make sure its enabled)

4 - Try a totally different harddrive

Repeat 1-4 until problem is fixed, or at least narrowed down.

I've had this issue with some HP machines that would refuse to see drives when connected to the IDE slots when BIOS was set to both. I very rarely need to load SATA drivers during win7 setup. You could also try accessing the Startup repair console and see if you can find your disk from there.

share|improve this answer

For me, the problem was caused by missing drivers. Windows Vista does not include the the drivers for my Serial ATA Controller. I was confounded by this because I had actually been to the driver page before, but dismissed them as being incorrect drivers because they were NVIDIA (NVIDIA makes SATA drivers?)

So using another computer, I downloaded the .exe, extracted the files with 7-zip, and copied them to an external hard drive.

I put the external hard drive in the problem computer, and this allowed me install the drivers by clicking Load Driver. Subsequently the hard drive was recognized and I was able to install Vista.

share|improve this answer

I had a the same problem when swapping a SSD with an HD. Before installing windows 7 from a non-OEM DVD, I tried to copy the first two partitions of the HD in linux using

dd ifile=/dev/sdx ofile=/dev/sdy bsize=4M

Which I stopped using ctrl+C after 32GB was copied (way more than the recovery partitions sizes, and they were all the the start of the disk). Of course, I also did "sync". Nevertheless, although the recovery tools started correctly from the SSD, there was no "fresh install" options. Since I'm not familiar with windows at all, and I was only doing this swap for friends, I decided not to look in to it too much, and bought a non-OEM windows 7 disk.

I booted the disk, but windows did not detect it: nothing was shown. Loading all the drivers I found on the manufacturers website did nothing but wasting time.

Ultimately I found that the original (untouched) HD was detected by the install disk, hence I concluded the error was not related to missing chipset or HD controller drivers. Hence I recreated the partition table on the SSD using gparted on linux, which needs to be MBR (msdos in gparted) for some reason, since GPT also does not work.

Concluding: Windows installation may not detect your HD if the partition table is broken.

share|improve this answer
disk part
list disk
select disk #
create part primary
select part #

Now that you've cleaned the drive & created a primary, active partition, it should show up during Windows Installation.

share|improve this answer
This doesn't explain what to do with those lines of text. Answers should be self-contained. Please read How do I write a good answer?. – DavidPostill Jan 11 at 18:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .