Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was just working on an Acer laptop (not mine, eek) when I discovered it only has 512MB ram. As I was loading Visual Studio 2008, I knew this wasn't an option, so I swopped it's memory out (two DDR2's), for 1GB. When I tried to boot the machine, immediately on power on, both build in and USB hard drive lights came on and the machine hung. There was no opportunity to enter BIOS settings or anything. I replaced the original ram with no change.

I am quite confident that merely swopping the ram couldn't have cause this, but what could have gone wrong?

share|improve this question
To me it seems like you somehow damaged it while swapping out the ram. Did you spill a coke in it or something? Maybe static discharge? I dunno – davr Sep 10 '09 at 17:08
disconnetct ac power, reomove the battery and press the power button. then reconnect and try again. – Molly7244 Sep 10 '09 at 17:13
Haha, no @davr, but the reason I'm working with this laptop is indeed that I spilled a sticky drink on my own laptop. I've never seen static fry a 'removable' component on a laptop, given normal environments. – ProfK Sep 10 '09 at 18:11
up vote 1 down vote accepted

If you've put the original RAM back in and it still doesn't work, about the only thing to try it to be SURE that the RAM is seated properly (I've had repeated problems in this regard with laptop RAM). If it starts working again, try the new RAM again.

However if it still doesn't work, you've probably accidentally let the magic smoke out of something.

share|improve this answer

Unplug the USB drive and try it again.

If that doesn't do it, then take one of the memory chips out and try it with just one. If that doesn't work, do the same thing only with the other. If you get it to go with one then you've got bad memory.

If neither work, put the original memory back in and see if it still works. If so then your new memory's either incompatible or both are bad. If not (and you've unplugged and reseated the battery) then you've got bigger problems...

share|improve this answer
I tried removing the USB, given that it was previously my main drive, and maybe the laptop 'mistakenly' tried to booted off it, but it made no difference. The memory I know was good, and the machine doesn't work with original memory either. – ProfK Sep 10 '09 at 18:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .