Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an application where I upload some content in CSV format, however the main document where I have my data is an Excel document.

I use Save As » CSV in order to make a CSV file, but it is not going to save the cyrillic values, instead the text looks like question marks (the system does not let me paste a lot of question marks here).

How do I export it correctly?

share|improve this question
    
What version of excel? –  Raystafarian Feb 19 '12 at 3:49
    
Microsoft Excel 2010 –  mugur Feb 19 '12 at 19:31
add comment

2 Answers 2

do you use correct encoding? I use Libreoffice Calc and there you have to specify output encoding for the CSV or DBF file (and there should be something similar also in Excel). I used this also with some Japanese datasets and it looked OK. I assume that you should use UTF-8 in your case.

share|improve this answer
    
Actually my Excel is saving CSV in ANSI and not UTF8 or Unicode and I do not know how can I change that. –  mugur Feb 18 '12 at 15:09
    
I also checked this but with no result superuser.com/questions/170926/… –  mugur Feb 18 '12 at 15:11
add comment

In Excel,

Save as, then next to the save button, you see "tools" menu. Choose web options, then encoding tab, then select the encoding you like. I would suggest to save everything in UTF8, but that is your choice. Note this is in Excel 2007 or above.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.