Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I start up my netbook without an internet connection, I might as well be using windows because it takes forever to start up waiting for "Starting MTA:" which eventually times out and continues my boot process. I'm using exim4, and I don't really want to completely get rid of it (even though I'm the only user on this machine) because some of the mails come from programs with some information that can be helpful.

I tried to change a few settings (since this is just for local mail to user accounts), but it didn't seem to make any difference (setting it to use minimal DNS gave me some error, I'll set it up again and see what it said)

How can I get this to just not take so long when I don't have a network connection? Honestly it shouldn't even need one, since it's all local mail from this machine to this machine.

Linux s10 3.2.0-1-686-pae #1 SMP Sun Feb 5 23:52:49 UTC 2012 i686 GNU/Linux

hostname --fqdn did not return a fully qualified name, dc_minimaldns will not work. Please fix your /etc/hosts setup.

I don't know what's wrong with my hosts set up. This is after running dpkg-configure exim4-config and setting up minimaldns as if I had Dial-on-Demand. hostname --fqdn returns s10

/etc/hosts:

127.0.0.1   localhost
127.0.1.1   s10

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
share|improve this question
    
I have the same problem. Have you ever found a fix for this problem? –  Nanda Aug 27 '12 at 5:59
    
Not really. I moved to archlinux and it doesn't have MTA on startup, so I guess just taking it out of whatever makes it start on boot and if there's trouble, adding it afterwards. –  Rob Aug 29 '12 at 16:47
    
I am guessing you were on Debian then? ;-) I read that if outbound mail is not needed the MTA on startup can be disabled. I will have to check how that works out. –  Nanda Aug 30 '12 at 18:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.