Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a new MacBook and have installed Xcode 4.3 with the command line tools. Homebrew is working so everything seems ok so far. I then installed MonoDevelop 2.8.6.5.

If I create a new MonoMac project then build, it fails with the following error:

Error: ibtool returned error code 1 (MonoMacTest)

If I run ibtool (no arguments) in Terminal I get the following:

Bens-MacBook-Air:~ ben_scott$ ibtool
xcode-select: Error: No Xcode folder is set. Run xcode-select -switch <xcode_folder_path> to > set the path to the Xcode folder.
Error: /usr/bin/xcode-select returned unexpected error.
Bens-MacBook-Air:~ ben_scott$

How do I fix this and get MonoDevelop working with MonoMac projects?

share|improve this question

This seems to work for me (on Lion):

sudo ./xcode-select -switch /Applications/Xcode.app

It depends where the Xcode is installed. It used to be installed in /Developer but now when installed from the App Store it is installed in the /Applications folder like all the rest.

And yes, it is an integration bug, where each application assumes the other is responsible for it and eventually no one does.

share|improve this answer
    
worked! but without './' -> sudo xcode-select -switch /Applications/Xcode.app Thanks!!! – Chakalaka May 4 '12 at 12:09
up vote 1 down vote accepted

It appears that setting the Xcode folder path to / works, or at least now I'm getting a different error (something about the MainMenu NIB file...). Set the path with this:

sudo xcode-select -switch /
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .