Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I do some scrolling with the middle button, often the page suddenly makes another jump and scrolls down after a short delay. This is very annoying if you just fixated on a sentence and the page moves away underneath.

System:

  • Windows 7
  • Firefox 10 - tried smoothscroll on/off
  • Microsoft Wheel Mouse Optical - driver version 8

Already tried:

  • another mouse
  • another Wheel Mouse Optical (same problem)
  • new drivers
  • cleaning the mouse
  • about:config -> smooth scroll
share|improve this question
    
clean it, try turning off Smooth Scroll in the System itself (in the effects section). Does the wheel still have more solid locations where it stops at? that has always been a peeve of mine, the balance between a clunking scroll, and it having to Stop in the right place, or it can even flitter back and forth. –  Psycogeek Feb 19 '12 at 10:58
    
bugzilla.mozilla.org/show_bug.cgi?id=635645 Could it have anything to do with the change in arrow scrolling? (2lines) . Depending on the program a scroll mouse will work 2 different ways, simulating the arrows for text , usually in browsers? –  Psycogeek Feb 19 '12 at 11:47
    
I have a seemingly similar issue with a "laptop mouse" from MS. I think the error is in the hardware (i.e. unfixable) –  Ярослав Рахматуллин Nov 26 '12 at 2:47

4 Answers 4

I know you've tried with another mouse as well, but just for luck, did you try another mouse in an alternate usb port ??

Next Goto Control Panel > Mouse > Wheel tab > and Change the Vertical Scrolling value to an increased/decreased value and see if there is any difference

share|improve this answer

I just installed the new driver for my MS Intellimouse (via Windows Update, optional update) and this problem started occurring. The wheel scrolls by page (screen) not by line. Mouse control panel settings are for 3 lines. Changing this setting back and forth did not fix it. Restarting computer did not stop it.

So I went to Device Manager and rolled back the driver for the mouse.
Now it acts normal.

share|improve this answer

If you have some other pointing device like touchpad, try to disable them or update their drivers.

I have Synaptics touchpad and I must disable it. Jumping stop after that. But new drivers does not helped for me.

share|improve this answer

Most likely there a problem in the mouse itself. Scroll wheel contacts need to be clean to work properly. I have successfully fixed these annoying jumps by cleaning scroll wheel contacts with isopropyl alcohol. Here some instructions if you decide to do that.

You'll need:

  • Phillips screwdriver
  • Isopropyl or ethanol concentrated alcohol
  • Cotton swab
  • Small pliers (optional)

Steps:

  1. Disassemble the mouse. Look for hidden screws if it doesn't open.
  2. Apply alcohol to the scroll wheel contacts. Visible amount of alcohol should soak inside.
  3. Scroll for a while in both directions.
  4. (Optional) Tighten wheel contact plate enclosure for stable electric contact.
  5. Let it dry for enough time. Wet wheel contacts wouldn't work. You can use hair dryer but only in cool air setting or the plastic may melt.
  6. Assemble mouse back in the same order. Check for polarity on battery module (+ is red).
  7. Done!

Also I made a short video with instructions how to do that with disassembly process included.

share|improve this answer
    
OP told that he already tried cleaning the mouse and even new mouse but the problem persisted so I think your answer will not help. P.S. Cute cat :) –  Davidenko Apr 5 at 16:24
1  
@Davidenko Well may be he cleaned it dry or outside only. This problem is common for Microsoft Wireless Mouse so it may help another people. P.S. Thanks :) –  asavartsov Apr 5 at 16:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.