Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have three disks, one GPT partitioned containing Windows 7 and Debian, the other MBR partitioned containing CentOS, and the other one MBR partitioned, empty.

It used to work (loading Windows boot manager using rEFIt) but now after installing CentOS and OpenIndiana on the second drive, Windows won't boot. The logo is displayed briefly and then a text mode scrollbar "Loading files", then back to the rEFIt menu.

The only thing that makes it work is if I drop into the UEFI shell and run disconnect XX where XX is the device handle of the other hard drives (obtained from running devices). This makes me think that the bootloader is getting confused about where the Windows partition is.

Is there any information on how the Windows UEFI boot loader finds the Windows partition, or is there any logging I can turn on to help troubleshoot this issue?

share|improve this question
add comment

3 Answers 3

I too have the G75VW. I added a solid-state drive in sda and removed the original hard drive. I used the backup DVDs (4 of them) to get the original Windows 7 installed and working. I then reinstalled the original hard drive in drive bay 2 (left).

I booted to the Linux Mint 13 Mate DVD by overriding the boot device in the BIOS (UEFI) and selected "something else" for partitions.

You will need a 1 MB partition of type "biosgrub", aka "Reserved for BIOS boot area". Next to that create a 202 MB partition of type EXT4 mounted at /boot. Add your swap partition (I set it to the same size as my RAM, but I don't know much about this question.

Then your usual partitions (one single / partition or maybe you like to split / and /home, whatever your preference here is fine).

Then the usual install happens, and then things go sideways.

This page shows how to install and use boot-repair to finish a normal dual-boot install of Ubuntu on a UEFI system (like the G75VW). Note about that: I used the Linux Mint DVD in live mode rather than the Ubuntu 12.10 CD (which won't boot anyway, black screen issue).

Tips:

  • The "Recommended" solution from boot-repair did detect UEFI on my G75VW.
  • Make sure you let the terminal commands finish before clicking on "Forward"
  • I chose "No" to the question of removing Grub2, but it looks like it may have been removed anyway.

After a reboot I was able to get the usual boot menu. Mint loaded fine.

share|improve this answer
add comment

I also unstalled Ubuntu on an ASUS G75VW and I would like to give some clarifications to the last post:

Windows 7 will not boot if you delete any of the NTFS partitions, as it will remove at least one of its volumes (C:, D:, E: and F: in my case), and it seems that Windows 7 keeps track of them at startup.

The recovery system will not boot either.

The solution is to shrink the NTFS partitions and not delete them. If you already deleted one, you can recreate it using gparted, and Windows will boot again. Another solution might be to delete the NTFS partition from Windows, but this need to be checked.

Other clarifications:

The ASUS G75VW uses the EFI boot system. This means that you have to install the 64bit version of Ubuntu (32bit version does not support EFI) and make sure that you boot your liveCD/USB in UEFI mode. This can be done from the bios or by pressing Esc at startup.

After the installation, I had to manually add an entry to GRUB, in order to boot Windows from grub's menu using the EFI system. The procedure is explained here.

Anyway it will always be possible to boot Windows by pressing Esc at startup.

share|improve this answer
add comment

I had a similar problem, with an ASUS G75VW, Windows 7 on 1st SATA disk with GPT and UEFI, and Linux Mint on 2nd SATA disk (without GPT). After many hours of searching and experimenting, I found a hacky fix, where I don't have to reinstall windows.

I shrank a Linux partition on my 2nd disk using gparted, and added a tiny 20MB NTFS partition (because Windows used to work when there was an NTFS partition on this disk).

After that, I booted Windows 7 on the 1st disk, ran startup repair (which worked this time), then start windows normally. It now works with the 2nd disk enabled.

I can now, finally, boot to either Windows 7 or grub->Linux through the UEFI boot menu. After all that trouble, I don't care to try booting windows 7 on GPT via Grub 2 at the moment! All this trouble, just so I can play some Windows games!

This was a real annoyance, it took me a long time to find this hacky fix.

I think the problem was due to:

  1. Windows is faulty (and they couldn't be bothered fixing it), see point 3.
  2. Windows was installed with multiple SATA drives connected
  3. Windows does not always register SATA drives in order. I saw this with diskpart.
  4. During boot, Windows expects to find some Windows partition on the disk it regards as 'first' (which was my 2nd SATA disk), even if it is empty.
  5. Perhaps MS deliberately neglected to fix this bug, as most users would blame Linux.

The problem was not caused by:

  1. Anything on the 2nd disk - it worked when that disk was removed.
  2. Linux / grub 2 install - I told Linux not to install anything on the 1st disk.
  3. Windows MBR or EFI boot files or anything on the 2nd disk. There is no sign of Windows on the 2nd disk except that empty NTFS partition I created.

To fix this more cleanly, with more effort, I might reformat the disks, disable the 2nd SATA disk in BIOS / UEFI (or physically unplug it), then install Windows 7 again from scratch. I suppose it would not then register the disks the wrong way around. I'm too lazy to try this, but I guess it would work.

I would like to know how to fix this nicely. I guess would have to somehow fiddle the Windows registry, so that the Windows disk order matches the SATA disk order, as it should.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.