Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable read Gmail in my Firefox browser on my laptop. However, there are no problems when I try to access Gmail on my office desktop. In fact, Gmail renders fine on IE on both computers.

Things I have tried:

  • Uninstalling and reinstalling Firefox.

  • Using Firefox 3.6.26 and Firefox 10; same problem.

  • Clearing the cache.

But all to no avail.

For starters:

  • My background image does not get loaded. It says "Oops. Your selected image failed to load".

  • The buttons for the new look do not get rendered, but when I do a mouse-over I see text which helps me navigate.

  • When I try to read a message, I see the subject line and I see the reply / forward box.

  • The message body does not get rendered, it seems like a styling error.

Check this screenshot where the icons in the GMail new look are not rendered properly

enter image description here

Check this screenshot where even facebook is not getting rendered properly

enter image description here

EDIT: 25th Feb 2012

GMAIL is getting rendered fine in the old look

share|improve this question
5  
a screenshot would be nice –  Journeyman Geek Feb 20 '12 at 5:28
1  
You bet it, will share it in a day !! –  Andy Feb 20 '12 at 8:49
    
@Andy: Although, it might not be, but did you ever tweak DPI(Dots per Inch) of your lappy? Asking because I'm facing a similar issue on Windows 8 Release Preview when I click on an image in FB timeline uisng IE10. It works fine in Chrome though... :) –  Daredev Oct 15 '12 at 6:27
add comment

4 Answers

Switch Firefox to private browsing mode then log into your GMail account and see if that makes a difference.

If that doesn't help then try running Firefox in safe-mode and see if that helps. From the command prompt type:

firefox -safe-mode

An uninstall/re-install does not wipe clean all of the browser local settings. After the uninstall you need to also delete the application data folder, includes your profile, and cache folder.

If you provide your Operating System I can try to give you more specific details.

share|improve this answer
    
i am on windows xp –  Andy Feb 23 '12 at 5:30
    
Hi I tried browsing in private mode but the issue persists !! –  Andy Feb 24 '12 at 12:05
add comment

Try creating a new firefox profile.

http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

share|improve this answer
    
Can you list the steps on that site? –  Canadian Luke Jul 19 '12 at 3:12
add comment

Check your router if there are any bandwidth limitations set. Use Firefox without any addons or plugins. Enable java-script in firefox.

Does it work with other browsers?

share|improve this answer
    
Trying a different browser seems like a very simple solution , I suspect the OP needs firefox for some reason . –  Keithsoulasa Dec 18 '12 at 7:00
add comment

Try to check your installed extensions(plugins), and trying to disable one by one.
Adblocks Plus extension sometimes can show this result on a different sites.

Answer is reference to this post

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.