Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a long story so I'll try to trim it down, please ask for any information.

This machine is running Linux Mint Debian, it's an ASUS A7N266-VM with GeForce2 Integrated Graphics [NVCrush11] that is targeted by the legacy drivers.

So, there I went to compile it. I booted into text mode, had the (.run) installer disable nouveau (which worked fine), rebooted (again in text mode), had the installer compile and set up the driver, and rebooted into text mode.

Suffice to say it was a mess of garbage, so I read the manual (again), looking for what it could be. It says something about AGP, so I disabled AGP with NvAGP X server configuration option to 0, and while the garbage on the screen was less pronounced, it still looks like this:
argh
Some things fail to re-paint, others paint where they should not, and it starts getting worse after opening applications until X crashes and restarts.

So, I've started X with high log verbosity, but I still can't figure out the problem. Here's the Xorg.0.log, and here's the xorg.conf.

Edit: After looking around, I've seen quite a lot of threads with problems on this drivers, and this graphics cards, (and nVidia in general) on Linux, just no fix! I'm still looking for a fix.

Please, help me find the problem! It will be very very appreciated :)

share|improve this question
    
"[ 149.657] (II) NVIDIA(0): Initialized GART." repeated many times - that looks very suspicious... –  pjc50 Feb 20 '12 at 16:54
    
@pjc50 I guess so, but I've never looked at a good one, so I don't know how it looks. By the way, what does GART mean? –  Camilo Martin Feb 20 '12 at 17:07
    
Google says "Graphics address remapping table" and that it's something to do with AGP. Don't actually know what it is myself. –  pjc50 Feb 20 '12 at 17:12
    
@pjc50 Well, as said, I disabled AGP, or at least I've set the relevant option to disable it. Actually, I even used the nvidia-xconfig utility provided with the driver to set the flag, in the hopes that it did something different. AGP should be disabled. –  Camilo Martin Feb 20 '12 at 17:43
add comment

1 Answer

up vote 0 down vote accepted

This makes it "work":

sudo nvidia-xconfig --no-render-accel --no-render-extension

But it's so bad it's not even worth it. Sorry nVidia folks, you suck at making a driver for your own board. I know it's an old board, but nouveau drivers are quite better.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.