Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm helping a friend to use Word 2010 for university work, and synchronising between two computers using SpiderOak.

I have the following problem, which would have been totally avoidable if Microsoft hadn't used the janitor to design the bibliography suppport:

  1. SpiderOak (quite rightly, in my opinion) will not synchronise anything in %APPDATA%

  2. Word stores the bibliography, by default, in %APPDATA%/Roaming/Microsoft/Bibliography

  3. If I move the bibliography to My Documents (which is where the janitor should have put it in the first place), anything I open now shows an empty bibliography, and I have to Browse for it. When I close the doccument, the location I have chosen for the bibliography data gets forgotten again.

I believe the best way to fix this would be to reset the default bibliography data location to somewhere in My Documents.

How do I do this? I can't find any option in Word, hidden behind the accursed Ribbon.

share|improve this question

1 Answer 1

You could possibly solve this by using the Symbolic link feature which allows you to redirect a source path to a different destination path in Windows.

The idea would be to direct the %APPDATA%/Roaming/Microsoft/Bibliography directory to point to any directory of your choosing in My Documents. I'm not 100% sure how Microsoft Word when it comes to load the bibliography resources and encounters a symbolic link. I successfully used the same technique to redirect iTunes from saving backup data from a hard-coded path on C:\ to an external USB so I do have high hopes for this working.

Take a look at this detailed instructions for setting up a Symbolic link under Windows 7.

Your steps will go like this:

  1. Open the Roaming/Microsoft/Bibliography path in Explorer.
  2. Copy the contents from inside the Bibliography folder to a new folder of your choice in My Documents. Let's call this BibliographySources.
  3. Delete the Bibliography folder under Roaming/Microsoft/Bibliography.
  4. Open Command prompt and cd to %APPDATA%/Roaming/Microsoft/.
  5. Run the mklink command to create a symbolic link: mklink /D \Bibliography C:\Users\MyName\Documents\BibliographySources - Try to avoid a path with spaces as you would need to use speechmarks to get it to work, however I could never properly such a path working correctly.
  6. Test that the link is working. You should be able to double click on the new Bibliography directory in Explorer and it will open straight to the folder in Documents (with all the files you first copied there).
  7. Open Microsoft Word and tests if the bibliography sources can still be found. If it does, you can now sync them from under Documents folder. Tell us how it goes!
share|improve this answer
    
Thanks, Adam. My friend is on vacation at the moment, but as soon as she gets back, I'll try this (I don't have Word on my own machine...) –  Brent.Longborough Jul 10 '12 at 10:52
    
@Brent, Sounds good, let me know how it goes :) –  Adam Jul 10 '12 at 10:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.