Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using dwm on Gentoo GNU/Linux, but GTK+ applications launched from it don't load the correct GNOME settings (fonts / styles). I've tried setting .gtkrc-2.0 and gnome-session. I can't find gnome-settings-daemon on Gentoo, since it's not in the package of the same name.

Does anybody know how to do this?

share|improve this question
up vote 1 down vote accepted

Gnome-Session-Daemon needs a dbus session to run. You do not specify how you are actually launching everything. The link below goes into starting gnome-session and/or Gnome-settings-Daemon.

http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.16-upgrade.xml?style=printable

Are you using a Login Manager? Or just launching from xinitrc?

If you are using xinitrc, you can launch like this -- after using something like lxappearance to set your gtk themes/icons.

exec ck-launch-session dbus-launch --sh-syntax --exit-with-session ~/bin/startdwm

With /bin/startdwm being an bash script

#!/bin/bash
#this file is called by .xinitrc to start some nice apps for dwm

xrdb -merge ~/.Xresources &

xfce4-power-manager &

sh ~/.fehbg &

while true; do
    xsetroot -name "$(date +"%a %d.%m/%H:%M:%S") $(df -h|grep root|awk '{print $4}')"
    sleep 1
done &

while true; do
    dwm || exit
done

https://wiki.archlinux.org/index.php/Dwm#Using_dbus_with_dwm

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .