Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

To test 'text boxes' in an application of mine, I need the physical keyboard to output Japanese to the screen. Does anyone know how this can be done?

The application is in a Virtual Machine (VMPlayer) running Windows Server 2008 R2. VMPlayer is on a Windows 7 64 bit machine to which the keyboard is connected too.

I've already tried the set the following 'Keyboard and Languages' option in Control Panel of the Windows 7 machine but the keyboard still outputs English on screen of the Windows 7 screen. So getting this to work on the VM is still far away.

enter image description here

share|improve this question
up vote 2 down vote accepted

You have to select the Japanese IME from the language bar.


Microsoft say

To enter Japanese characters using a standard U.S. keyboard on a localized Japanese version of Windows NT, you must use an Input Method Editor (IME).

IME provides several different methods of entering Hiragana, Hurigana, Katakana, Kanji, and Romaji characters using Microsoft IME, WX2, VJ2, and ATOK7. The Microsoft IME input method is used by default. To change the default input method, run Microsoft IME from the Program Manager "Nihon go jin ka" group.

To invoke IME, you must use the key combination ALT+~ or ALT+` to launch 4 applications (located in the lower right hand corner on your desktop). These applications provide several Japanese characters you can enter into your document. To disable IME, you must use the same key combination of ALT+ ~ or ALT+ ` again

There's an old but informative article that describes some of the input methods.

I'm not actually familiar with Japanese IMEs but they may be similar to Chionese ones which fall into several types

  • romanised pronunciuation. There's an official way of spelling the Japanese pronunciation using Latin letters. you type the latin letters, the IME inserts Japanese characters that sound like that (usually you get offered a list of characters and pick one)

  • shape-based. You know the order and direction of the strokes that make up a character. You press a key that corresponds to a group of initial stroke shapes (e.g. vrtical line or left downward slanting line, box or cross) you repeat for subsequent strokes (or for first two and last two or some other such system)

  • you draw a character with a mouse

  • you use a key that indicates a radical (a common element found in many characters) There is usually no obvious correspondence between the latin letter and the radical, you have to learn them.

share|improve this answer
I have checked an option called JP Japanese (Japan) from the language toolbar. Is this correct? In another option on the tool bar, I can check between 'Microsoft IME' and 'Japanese'. I checked Japanese for this. However, the keyboard still types in English. – Thomas Feb 20 '12 at 18:42
@Thomas - Silly question...this is a Japanese keyboard, right? Or is this a US/UK/etc keyboard and you're trying to use the IME? If it's a native English keyboard you HAVE to use the IME, I believe... – Shinrai Feb 20 '12 at 19:01
US Keyboard. Also, I set the IME option in both Control Panel and the Language Bar. Still nothing. I feel like I have to restart something. (the Windows feeling). Have you been able to change your keyboard to output Japanese? Hopefully I'm not asking for too much but a step-by-step on how this is done would be great. – Thomas Feb 20 '12 at 19:06
That old but informative article, helped. Thanks. – Thomas Feb 24 '12 at 6:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .