Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded to OSX Lion and it destroyed my logic board. I am forced to set the graphics card to integrated only using an application called gfxCardStatus. I now have the same problem on Ubuntu, it crashes when using the NVIDIA (discrete) chip.

How does one turn off or set the graphics card to the integrated card only in Ubuntu?

share|improve this question

2 Answers 2

It's not possible for me to use integrated graphics for the following reason.

  • UEFI boot allows the kernel to see both graphics devices while the BIOS emulation is only seeing the discrete graphics [source 1]
  • The Ubuntu installer will try to setup UEFI boot during installation, but it's better to avoid this because this can corrupt the firmware as the EFI partition of the mac is reformatted to FAT32 (original is Apple_HFS). [source 2]

I've installed Ubuntu 12.04 on my Macbook using both the alternate+mac iso and the standard desktop iso image (which also works for Macs).

Unfortunately, both times the installer choose the BIOS emulation instead of UEFI. Therefore, I can't use the integrated graphics.

share|improve this answer

Try this ubuntu documentation steps to set up the graphic card however the steps are for Nvidia but I think you can try them with ATI too.

As user posted his article.
note: this script broke my fresh installation so not sure it s a good idea to use it.

Apple uses 6-bit LCDs which support only 262144 colours instead of 16 million. So we need to enable dithering at 6 bits per colour channel to smooth colour gradients.

Assuming you use gdm (the default) as login manager, run:

sudo gedit /etc/gdm/Init/Default

Add to the end of the file, but above the exit 0 line:

/usr/bin/nvidia-settings -a [gpu:0]/Dithering[DFP-2]=1 /usr/bin/nvidia-settings -a [gpu:0]/DitheringDepth[DFP-2]=1

To fix backlight and touchpad issues with suspending, create a new file:

sudo gedit /etc/pm/config.d/macbookair_fix

And add these lines.

SUSPEND_MODULES="bcm5974 mbp-nvidia-bl" HIBERNATE_RESUME_POST_VIDEO="yes" ADD_PARAMETERS="--quirk-reset-brightness" DROP_PARAMETERS="--quirk-none"

To fix the backlight function keys:

sudo gedit /etc/X11/xorg.conf

Find the Device Section for the Nvidia driver and add this line to the end of the section:

    Option          "RegistryDwords" "EnableBrightnessControl=1"

The block should now look like this:

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Nearly there, we just need to change some boot parameters now:

sudo gedit /etc/default/grub

Change the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splas" to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=pci acpi_backlight=vendor"

Now, finally run:

sudo update-grub

To install ATI's proprietary driver, as it is not installed by default due to licensing issues.

Go to System->Administration->Hardware Drivers, and search for new drivers. The ATI proprietary driver should appear, enable it, and then restart X.

If it doesn't find it automatically, you can use the legacy ATI driver (cat 9.3) found here.

On this for more details see this discussion.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.