Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have questions about turn off parenthesis matching. Does anyone know how to turn off parenthesis matching?

example:

When I type a (, it will automatically add ), becomes ().

It's pretty nice for editing plain text. But quite annoying while editing clojure files.

share|improve this question
up vote 42 down vote accepted

Set this in your User settings

"auto_match_enabled" : false
share|improve this answer
    
Thanks, it works! – juanitofatas Mar 19 '12 at 14:57
    
Can you make it a toggle switch? – laggingreflex Aug 11 '12 at 23:08
9  
You'd be better off adding that line to the User settings (Preferences > Settings - User) rather than global so that they're not overwritten by updates. – pelms Oct 3 '12 at 11:38

You can toggle this setting by adding a key binding to 'Preferences > Key Bindings - User'.
e.g. to make Ctrl+Shift+p toggle the setting, use:

{
    "keys": ["ctrl+shift+p"],
    "command": "toggle_setting",
    "args":
    {
        "setting": "auto_match_enabled"
    }
} 
share|improve this answer

It sounds like you need to change autoMatchEnabled to false under File Type Preferences to disable auto pairing. Read more about it: http://www.sublimetext.com/docs/file-type-preferences

share|improve this answer
    
Thanks Sam! it should be there. But I set "autoMatchEnabled":false @Global.sublime-settings, restart, still not working. – juanitofatas Feb 23 '12 at 2:33
    
I miss the spaces ... Thanks! – juanitofatas Mar 19 '12 at 14:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .