Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On all Windows versions, when I disable the "Language bar" by right clicking on the taskbar and unchecking "Language bar" under Toolbars I find that a short while later it is checked again.

How do I disable this permanently?

share|improve this question
up vote 6 down vote accepted

Check the Control Panel language settings. There are options to show the language bar under certain scenarios; disable the language bar there and it should banish, never to return. (It took me forever to find this in the past, too.)

This blog post from Paul Stubbs describes behavior much like what you are experiencing, and links to this Knowledge Base article with the nitty gritty details.

share|improve this answer
screenshots for an assist: & – warren Apr 26 '10 at 13:32

Instead of right clicking on the task bar and unchecking the language bar, right click on the language bar itself. From there, select preferences, and unselect "display language bar".

share|improve this answer

Unregistering the DLL worked for me when disabling it via control panel keyboard and language settings didn't.

Open a command prompt and type Regsvr32.exe /u msutb.dll

share|improve this answer
I've never seen disabling via Control Panel fail before ... I could be wrong, but I get the feeling OP hasn't found the setting in the control panel yet. (It is hard to find, IMHO!) – John Rudy Sep 10 '09 at 19:49
It very well could have been an external force re-enabling it for me after I disabled it from the control panel, but the control panel definitely didn't do it in my case. Unregistering the dll did it. – squillman Sep 10 '09 at 19:52
That's wild. I'd still recommend starting with the Control Panel, and only going nuclear if needed. :) – John Rudy Sep 10 '09 at 20:07
Yeah, I do concur. Nice to have a full arsenal when you need it though :) – squillman Sep 10 '09 at 20:16


Control Panel\All Control Panel Items\Notification Area Icons\System Icons

you can turn off the input indicatorenter image description here

share|improve this answer
That works on Windows 10 too! Even hiding the the language bar from "old" (win 7) settings, did not work. – superjos Jul 31 '15 at 9:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .