Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I create a new label in my Gmail account, this creates a new IMAP folder. Sadly, that new folder does not show up in Thunderbird unless I restart Thunderbird.

This is not specific to Gmail. When I create a new IMAP folder on my own server, the result is the same.

To clarify. Here is what I'm doing. First, I create a new label in Gmail: enter image description here

But now it won't show up in my Thunderbird folder tree. Even though it knows about the folder and it is subscribed to: enter image description here

When I restart Thunderbird, the folder shows up just fine. I would like it to show up without restarting Thunderbird.

share|improve this question

6 Answers 6

up vote 41 down vote accepted

In version 10.0.2 (current) and most recent versions:

Click on the account line in the folder tree (the line just above the Inbox)

You should get a screen of options, find Manage folder subscriptions and click on it

  1. Click the Refresh button
  2. Close the folder list window
  3. Click the little triangle at the top level of the account in the folder tree to hide the folder list
  4. Click it again to show the folder list

I've just confirmed that this works for me in 10.0.2

share|improve this answer
That doesn't do what I want. The new folder appears in the subscription dialog (and is subscribed to). But it won't appear in my folder tree. – Oliver Salzburg Feb 21 '12 at 14:11
Weird. I have Gmail set up in Thunderbird at home, and will check if its working there when I get home, but this definitely works for me with other IMAP providers. – Randy Orrison Feb 21 '12 at 16:42
Didn't work when I tried it, but after collapsing and reopening the folder list in Thunderbird it appeared. I've edited the answer to include those steps. Work for you? – Randy Orrison Feb 23 '12 at 20:31
Every time I tried it, I was already subscribed to the new folder. So that wasn't the problem. What actually made the difference was collapsing and expanding the tree. Thanks ;) – Oliver Salzburg Feb 23 '12 at 20:43
I had the collapse/expand the parent folder (not the top level folder), not the top level folder for these steps to work. – justderb Sep 29 '14 at 0:09

As none of the proposed solutions worked for me to get the disappeared subfolder to show in the sidebar on the left, I had to try something else. For me the folder was suggested on right click as a folder to put mails, but I had to create specific filters in the search field to view the folder, because it didn't show up in the sidebar.

My solution was to permanently rename the folder - for some reason it disappeared again if I renamed it back to the original name.

share|improve this answer
Renaming did the trick for me when everything else failed. – Olaf Oct 29 at 9:29

(Somewhat) surprisingly, in 2015, with Thunderbird 38.2.0, forcing Thunderbird to refresh the IMAP folder tree after adding a new directory/folder is still necessary.

I'm amazed that the answer is exactly as Randy Orrison described and Oliver Salzburg confirmed, above, over 3.5 years ago: How can I force Thunderbird to reload IMAP folder structure

Every time I tried it, I was already subscribed to the new folder. So that wasn't the problem. What actually made the difference was collapsing and expanding the tree. Thanks ;)

I had quit and relaunched Thunderbird, double-checked that I had subscribed to the IMAP folder in question, subscribed/unsubscribed, quit and relaunched again... nothing forced the new directory to be displayed — until I twirled-up and twirled-down the little arrow immediately to the left of the Inbox (in the folder pane panel). As soon as I did that, the new directory appeared!

It's curious to note that the new IMAP directory in question was "two levels deep", too. The structure was Inbox -> Subdirectory 1 -> Subdirectory 2, where Subdirectory 2 represents the IMAP directory that was just added. I mention this mostly to assert that the depth of the directory whose "arrow is twirled" seems not to matter, as long as the twirled directory is a parent of the directory that won't appear. Maybe twirling the top-level arrow, next to the account name, is the best option, since presumably it will force all subdirectories to be displayed (I didn't try that).

Thanks to everyone who contributed to this most frustrating problem's resolution! Full credit to Randy Orrison for the original solution.

Who's game for opening a bug report (or citing an existing report)?

share|improve this answer
If I understand your post, this is just commending other posters for something that worked for you rather than introducing another solution. Answers should really be reserved for solutions to the question and each answer should provide another solution. With a little more rep, you will be able to upvote useful answers and post comments with supplementary helpful information. – fixer1234 Sep 9 at 23:30
Thanks, fixer1234. Having read your thoughtful remarks, and having reread the accept answer more carefully as a result, I agree with your assessment. I feel it prudent to note, however, that the accepted answer instructs the user to "Close the folder list window", which is where he or she lost me. Maybe I use some "old school" view that is bound to my Thunderbird profile, but I don't have a "folder list window"; it's displayed permanently as a "docked pane" at left of my screen. When I saw this step, I ruled-out the answer, focusing only on the key comment. – Ben Johnson Sep 10 at 2:32
  1. Click on the account line in the folder tree.
  2. In the main window click on the Folders management (Settings section)
  3. Click on the refresh button
  4. Choose folders for synchronization
share|improve this answer

If you uncheck Tools » Account Settings » Settings » Advanced » Show only subscribed folders, it will display all folders.

That worked for me.

share|improve this answer

I think in that website you can find more useful information about Gmail x Thunderbird. Also, I found out in other forum the following:

Thunderbird refreshes the folder list when it connects to the server, in particular, at startup. You can force a refresh of the folder list any time by collapsing and re-expanding it.

Collapsing and expanding the folder list for the whole account worked for me.

share|improve this answer
Yes, that's what I was missing as well. Thanks :) – Oliver Salzburg Jun 29 '12 at 16:17
+1 I just wanted to use Thunderbird to move mail from a certain label to another account (like…), and I also had to remove my subscription to the Inbox to get it to actually start. – jnylen Mar 2 at 18:41
This is the correct solution -- tested for Thunderbird 38. – Jan-Philip Gehrcke Oct 5 at 9:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.