Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to open cmd with admin priviledges. That's because when executing a command I received a message that I don't have sufficient priviledges to run this command (mklink).

The problem is that I don't see an admin or Administrator account on my Win7 computer. When I go to Control Panel -> Accounts -> Manage other account, there are only 3 accounts:

  • MyName
  • ASP.NET Machine Account
  • Guest

MyName account is of type Administrator, so I think it should have administrative priviledges. That's the account I am currently logged in. However, for some reason, it is not sufficient to run mklink command.

How to solve this problem?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You need to run the cmd.exe program as administrator. Find the cmd.exe program and right-click on it, select Run as administrator.

enter image description here

share|improve this answer
    
Thanks! Yes, finally. I've read before to run cmd.exe as administrator, so I thought to "runas /user:Administrator cmd" but there was no such user etc. The "cmd" is well hidden under "Accessories" by the way. –  camcam Feb 21 '12 at 19:25
    
If you drag a shortcut of cmd to the desktop, then right click on the shortcut and select properties, then click "advanced" on the shortcut tab, tick the "run as administrator" box, hit ok then apply, now when you open command from that particular shortcut it will automatically run as administrator. –  Moab Feb 21 '12 at 19:59
    
I found it! Very useful setting indeed. –  camcam Feb 21 '12 at 20:15
add comment

First: account names have less to do with permissions than the groups an account is a member of.

If an account is a member of the Administrators group, or, as in your case, is of type Administrator, that account is an administrator account and should have sufficient permissions.

While you may not see an account NAMED Administrator, you have an account that IS Administrator, which is better.

The bigger issue is whether the administrative account has permissions to run mklink inside the directory you're trying to work in.

You should be able to adjust the folder permissions (right-click on the folder, select properties, select Security tab, change permissions or take ownership as necessary).

What folder are you trying to run mklink in?

share|improve this answer
    
For the purpose of this test, I made a new folder "d:\temp". In this folder I made folder "ps". In cmd window I navigated to d:\temp and entered command: mklink /D mylink ps and the message about insufficient priviledges appeared. I didn't set any specific rights for this folder and under "Properties/Security" it has "Full control" checked for Administrators group. There is 1 option at the bottom and it is called "Special permissions" and it is unchecked, perhaps it is irrelevant. My filesystem is NTFS and I don't have any disk software or anything that manages file access - just Windows. –  camcam Feb 21 '12 at 16:05
    
What version of Windows 7 are you running: Home, Professional, Ultimate, etc? –  music2myear Feb 21 '12 at 16:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.