Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My relative brought this to my attention a little while ago. They told me they turned on their computer recently and the color red did not appear on their GUI. Has this ever happened to anyone and why would it happen?

share|improve this question
1  
I've had green break before - the rest of the display is pink in that case. Is the rest of his display tinted blue/green? Red objects would appear black in that case. (All three answers below are proposing this possibility) –  Random832 Feb 22 '12 at 20:04
    
All of these answers and comments are definite possibilities. The obvious thing is I have to see the monitor myself first. I'll have to ask my relative to bring over the monitor and tower. Using my monitor, perhaps I can find out if it's a monitor issue or an internal issue from the get go if my desktop monitor has problems on the GUI or not. –  Christopher Chipps Feb 23 '12 at 7:55

3 Answers 3

There's a few possiblities - the red channel isn't getting sent to the system - this may be a fault somewhere along the signal chain - video card failure, issues with a cable, or something inside the monitor breaking.

share|improve this answer
1  
@Christopher Chipps See also here. superuser.com/questions/347383/screen-went-pink I have seen the VGA analog not have one wire fully connected Many times, because here we do not screw them in fully, because if they get jerked on it can break things. if the vga connection is not inserted well, it can easily knock out one of the R-G-B connections. If it is a Color thing, not whole colors, a profile might be at fault. –  Psycogeek Feb 22 '12 at 6:59

Have you seen the red-less GUI yourself ? Technically, it is possible your relative's computer is ok, but but his/her vision is impaired.

In the real world however, the first thing I would advise them to check is a half-loose plug. It is possible that the video card or the monitor are broken with respect to the red channel, but in 20 years of computer maintenance, I have not seen that happen for one single color; in my experience, graphics cards and monitors either live or die.

Issues that usually cause problems like that (and also prevent proper visual inspection):

  • computer case is under the desk and most people don't like crawling under them; elderly people might physically not be able to
  • there is no light under the desk / behind the computer case and people can't find a working torch, so they try to 'feel' the right plug, but usually don't get the right one
  • the computer case is 'built in' tightly with no cable slack, so whenever you want to move the case (e.g. to pull it out and look at the back side), some cables come loose
  • there is a mess of (often dusty) twisted and tangled cables behind the machine and to a layman's eyes, it's unclear what cable goes where

Speaking of dust: Years ago, I had the weirdest freezes on an ancient machine that'd been sitting in a dusty workshop for years. The owner was already about to buy a new one when took it all apart and blew the dust with compressed air out of every cooler grill, fan, case corner I could find (like e.g. IDE slots - this is the 90s ;-). Worked like a charm afterwards for many years more.

Ideal solution: Go there yourself, take it all apart and give the machine a good mechanical cleanup. This takes not longer than one hour and will save you from computer help requests from friends and family for at least a few years. Plus of course the computer runs much faster afterwards ;-)

share|improve this answer

Old CRT monitors would occasionally get a loose connection in one of the guns in the CRT tube. You could often momentarily cure it using percussive techniques (slap upside the monitor) and have the fix work anywhere from 10 minutes to two weeks. The worst was the old Zenith flat screen CRT's. They used a lot of small boards, interconnect cables and the guns could go into a round robin failure if the monitor got dropped. I think the support elements for the electron guns were weak.

Modern equipment using LCD/LED technology can experience this when a pin gets bent (common failure in the HD-15 type connectors, why DVI or HDMI is better). I've seen them folded over into a 90 degree dogleg and fixed it with a bit of patience and a pair of needle-nose pliers and a recommendation to never remove the cable unless the system was being moved out of the house as the pins would probably break the next time they got bent.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.