Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm trying to install subversion on a Ubuntu machine using command sudo apt-get install subversion, it's throwing the follwoing error.

~$ sudo apt-get install subversion
[sudo] password for hwsui:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  subversion: Depends: libsvn1 (= 1.6.5dfsg-1ubuntu1~jaunty1~andersk1) but it is                                                                                         not going to be installed
              Depends: libapr1 but it is not installable
              Depends: libaprutil1 but it is not installable
              Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installab                                                                                        le
              Depends: libneon27-gnutls (>= 0.28.2) but it is not installable
              Depends: libpq5 (>= 8.3~beta1) but it is not installable
E: Broken packages
share|improve this question
    
Did you run apt-get update before the installation? –  user119576 Feb 22 '12 at 8:28
    
FYI - I did run sudo apt-get update and I see something very similar. –  sage Apr 8 '13 at 22:35
add comment

1 Answer

You can try to run the apt -get with a -f parameter to attempt to correct a system with broken dependencies.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.