Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In any version of Windows I have used so far (Xp, Vista, 7, 8) and all versions of the MSPY IME (RTM versions and the 2010 version) There is this annoying bug that you cannot change or disable the hotkey for Chinese shape troggle (normal to double spaced chars). The default is Shift+Space, and cannot be changed from the language input settings pane in the control panel. Here are a couple screenshots to show the problem:

Shape Toggle

After that press Change Key Sequence

This dialog will appear:

Hotkey Change

Disabling it, has no effect, i.e. Windows will ignore the setting. You will notice I already managed to change the sequence to Shift-None by using the registry, but Windows still uses Shift+Space for shape toggle, which is really annoying when you type Chinese faster (especially if you want to switch between English and Chinese).

Now after you changed or deleted the key with the dialogue, the setting will not be persistent with hitting Apply. Changing the corresponding registry value and rebooting also doesn't help, as the following screenshot demonstrates:

After Registry change and reboot

I hope anyone has experience with this problem.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
+100

Why can't you change the Shift+Space combination to some unlikely combination like Alt+F12 or whatever ? This is not the same as totally disabling it, but it will liberate at least the space-bar.

As more experimentation, I believe that this key-combination is defined in the registry at :
HKEY_CURRENT_USER\Control Panel\Input Method\Hot Keys\00000011.

Export this registry-key to a .reg file and change the following items :
Key Modifiers to "00 C0 00 00", meaning no "Control" or "Shift" or "Alt".
Virtual Key to 0, meaning "None".

If this does not work, maybe a more forceful action is required, such as totally deleting the 00000011 key. Unfortunately also, this thread claims that Windows will reset these keys as soon as they are changed, which you can verify on your computer,

(The above is based on Simplified Chinese MSPY 3.0 IME Hot Key Registry Settings.)

A reboot is required to be absolutely sure that any such change had an effect.
Create also, as a safety measure, a system quite-point before modifying the registry.

[EDIT]

It seems like Windows will not suffer a change to the above registry keys, so any changes are immediately nullified.

The only working solution is to use AutoHotkey to replace the Shift+Space combination to something else.

One possibility is detailed here : "+Space::Space".
The poster actually used "+Space:: WinActivate".

share|improve this answer
    
I tried that, doesn't work, I guess the hotkey just ignores the registry value (thatswhy cannot change it from the dialogue) –  Sebastian Godelet Feb 25 '12 at 18:52
    
Does defining it as some unlikely keys-combination works with reboot? –  harrymc Feb 25 '12 at 19:04
    
tried that, e.g. just changed the Virtual Key to some other value, no use. Embarrassing is that even in Windows 8 that bug still exists, I wonder how to file a bug to Microsoft for that. –  Sebastian Godelet Feb 25 '12 at 19:07
1  
Then this combination is immutable. But you can still disable it by using a product such as AutoHotkey. See this. –  harrymc Feb 25 '12 at 19:36
1  
That's normal on this site - poster and answerer working together. But I have updated the answer. Feel free to update it some more. –  harrymc Feb 25 '12 at 22:08
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.