Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Belkin G Wireless Router, purchased a few months ago.

The network disconnects very often when performing large downloads, or when doing many Internet related tasks, or just randomly. In-fact, what one user is doing usually ends up disconnecting every other user from the network. However, the desktop computer, which is where the router is connected to, functions perfectly normal despite this happening.

I have the channel currently set to 6 right now. Belkin originally told me that it's the wireless channel that causes this when it is set to auto, but now is no longer the case. I'm constantly reconnecting m. I have checked my firmware, and it seems up to date, so that cannot be an issue.

So, I ask, how is this problem caused, and what methods can I use to determine the culprit? I have wireless phones in the house, yes, but with other wireless networks that I have connected to before throughout the apartment, this has not happened. I am definitely sure it has to be an issue with my configuration or with the router itself.

I am using Ubuntu Linux right now. I have another laptop that operates on Vista, and like every wireless user, experiences the same issues.

share|improve this question

6 Answers 6

I haven't found any documentation that says you can control connection speeds directly on the Belkin Wireless Router.

Is the Wireless adapter also your Broadband Modem (or do you have a spare)? If not, if you have an old computer lying around you could set that up running IPCop (or similar) and use it to control connection speeds, this will allow all users to have a fair go at using the Internet.

share|improve this answer

Ensure it stays cool.

Change channels to a randomly selected channel. ( use dice ? )

Make sure everyone has the same time-of-day. This might meanu making sure the router has NTP enabled.

The router, and all the PC's connecting need to have the same time. otherwise part of the wireless security (the TKIP) fails.

And set the MTU for the router to 1400. that way your packets can be encapsulated over PPOE etc without fragmentation. Fragmented packets don't work if anything along the way uses a microsft TCP/IP stack. ISP ? Router using XPE ? who knows.

share|improve this answer

To piggyback on one of Ciaran suggestions, you can use inSSIDer to help track strength of signal.

Also, what kind of materials is your home/office constructed with? Some materials can interfere/disrupt a wireless signal.

share|improve this answer

If you're living in a fairly dense area there could be other Wireless G networks operating on channel 6. You should look into an app like Kismet and see what channels other networks in the area are operating on and adjust yours accordingly.

You could also try assigning static IPs to all computers on the network (or at least the ones you will be using the most).

That said, I recently had a problem with my computer disconnecting because of WPA strangeness surrounding TKIP (I think). Try changing the encryption method on the router?

I hope this helps!

share|improve this answer

Belkin routers aren't great. Check the link

With that said and out of the way, here's a couple of things to try.

First, unplug your cordless phone from power. See if the drops are still occurring. Second, work your way through the channels and see if anything works better than 6. Third, replace the router.

You've already isolated the problem as being the router - borrow someone else's if you need proof that the router is the problem.

I'm not sure that your particular router supports wireless N or A technology but if it does, those particular technologies broadcast at completely different frequencies to most cordless phones, so that would take them out of the picture

Edit: If you need to replace your router, I'd suggest looking into Linksys or Netgear brand routers

share|improve this answer
    
In the case that I Have to replace, what brand do you recommend? –  Gygin Sep 10 '09 at 22:32
    
Linksys or Netgear –  Ciaran Sep 10 '09 at 22:36
2  
"Belkin routers aren't great." i can only secand that :) +1 –  Molly7244 Sep 10 '09 at 22:44
2  
"Wireless routers aren't great" is more like it –  Joe Philllips Sep 10 '09 at 23:48

I have a Belkin and had similar problems. One thing which helped was to reduce overheating- turn it off regularly, prop it up so that the vents underneath are more exposed.

Try changing channels as well, as Ciaran said.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.