Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a D-LINK DIR-615 router, and wired devices have no problem getting an IP, however; wireless devices end up with a 169.254.. address (subsequently, they cannot access the internet through the router).

I have removed all wired connections from the router, so there is no other dhcp server running.

I've also gone back to the store, and replaced it with another, thinking that maybe it was defective.

According to the router, it gave 192.168.0.101 to the wireless device. According to the wireless device it got 169.254.67.71.

I've tried both a laptop and an iPod Touch, both exhibit the same behaviour.

Has anyone seen this type of behaviour, or have any ideas of stuff to try?


NEW INFORMATION

I looked at the logs on the router, and when the wireless device tries to connect, this is what is logged:

Sep 10 18:13:39  UDHCPD sending OFFER of 192.168.0.111  
Sep 10 18:13:31  UDHCPD sending OFFER of 192.168.0.111  
Sep 10 18:13:26  UDHCPD sending OFFER of 192.168.0.111  
Sep 10 18:13:23  UDHCPD sending OFFER of 192.168.0.111  
Sep 10 18:13:21  UDHCPD sending OFFER of 192.168.0.111

I connected a computer directly to the router, and here is what it looks like:

Sep 10 18:14:18  UDHCPD Inform: add_lease 192.168.0.110  
Sep 10 18:14:14  UDHCPD sending ACK to 192.168.0.110  
Sep 10 18:14:14  UDHCPD sending OFFER of 192.168.0.110

Not sure if that helps or not.

share|improve this question
    
Try setting a static IP address. Sounds like there's a problem with the encryption keys, however. –  Breakthrough Sep 10 '09 at 22:28
    
That's weird. Are you sure the address its giving isn't 169.254.67.71? –  Ciaran Sep 10 '09 at 22:31
    
Sorry, it was 169, I've changed the question. Thanks. –  mlsteeves Sep 10 '09 at 23:41
    
I tried the static IP, but I can't connect to the router's webpage. –  mlsteeves Sep 10 '09 at 23:47
add comment

7 Answers 7

It sounds like you are getting a 169.x.x.x address and are not actually connecting to the router. Please follow the following steps to try and reduce where the problems could be located.

Try resetting the password for your current wireless network first. This is Windows XP specific, but can be adjusted to Vista/7:

  1. Right click wireless network icon in your system tray and select view wireless networks
  2. Click Change Advanced Settings
  3. Click the Wireless Networks Tab
  4. In the preferred networks should be your SID. Double Click the entry
  5. Now you can try re-entering your network key.
  6. If you now attempt to reconnect and still get an error, follow these steps again but this time instead of double clicking your entry, click remove.
  7. Now try to reconnect through the wizard and you should be connecting now.

If that fails try doing the following steps:

  1. Check your revision and update to the latest firmware
  2. Do a factory reset to clear any previous settings
  3. Setup the router and your wireless information (use a different sid this time for checking)
  4. Connect your laptop to the wireless connection using SID and password setup in step 3
  5. You should now have access to your LAN and the Internet
share|improve this answer
1  
Just to note: the 169.254.X.X/16 address range is known as the APIPA range (Automatic Private IP Address). Windows will self-assign to such a range if DHCP fails. –  ultrasawblade Apr 8 '11 at 21:04
add comment
up vote 2 down vote accepted

I have figured out my problem.

There is an Enable Auto Channel Scan option, when this is checked off, it seems to be defaulting to channel 1. If I turn that option off, and set the channel to something else, everything works good.

I would say that there is some serious interference on channel 1.

share|improve this answer
    
Try checking D-Link website for a firmware update. Also listen to @Ciaran. Get DD-WRT on that as soon as it is available. –  ultrasawblade Apr 8 '11 at 21:03
add comment

Disable wireless security and see if the problem persists.

I'd also recommend installing DD-WRT firmware on the router

share|improve this answer
    
Disabling wireless security had no affect. On the DD-WRT site, the DIR-615 is listed as WIP. :( –  mlsteeves Sep 10 '09 at 23:43
add comment

I always though it was a problem on iOS side, not the router... Since the same happens to me when trying to connect to public WiFi's in general (hotels, cafés, etc.), only being able to get a good IP after several attempts on the iOS device. Anyway, fixed IP addresses are the way to go on your home network; they also improve connection establishment speed to the WiFi network.

share|improve this answer
add comment

I had this problem as well. 2 iTouches and a Windows7 laptop could not get a proper IP address via DHCP, but would work normally if I manually set the IP. My MacBook, however, seemed to properly get an IP.

I then discovered that the issue was that the local time on the router was incorrect, set about 18 months in the past. You can view the time settings by going to Tools -> Time.

I suspect that it was giving out DHCP leases, but since the leases were in the past, the client PCs and the iTouches were unable to accept them.

Once the time was set to the current actual time, all devices properly got an IP address.

share|improve this answer
add comment

Well it seems that it's not good enough to just change the channel away from 1. You just seem to need to change the channel around from time, i.e., every time the connection drops.

share|improve this answer
add comment

With my Virgin Media-supplied DIR-615 (although without the IP addresses being in the 169.254.. range) I solved it by turning off Wireless N in the advanced wireless settings.

My channel settings are stuck too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.