Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an irssi running forever under a "screen" in a remote linux server system. I have fedora 16 in my laptop and ssh into the server and resume my irssi screen when I come to work.

But I miss a lot of chats as I don't get any notification beeps from irssi. I want my laptop to beep for new messages in my subscribed channels. Please help.

Thanks in advance.

share|improve this question
    
possible duplicate of superuser.com/questions/20707/to-make-irssi-system-beep – jjlin Feb 23 '12 at 6:52
    
@jjlin It's not a duplicate. If I follow the answers in your link, it would beep on the server. I want the beep on my laptop. My question is different. – Vigneshwaran Feb 23 '12 at 7:13
    
Why the heck is it not beeping for you within screen? Have you disabled the bell in your terminal emulator? As they say, It works for me(TM). – Zoredache Feb 23 '12 at 8:30
    
@Zoredache Does the remote irssi beep for you in your local machine? What command you used? – Vigneshwaran Feb 23 '12 at 11:52
    
ssh via putty, xterm, or xfce-terminal all seem to work. – Zoredache Feb 23 '12 at 16:47

Try the steps @jjlin commented above to ensure your pc speaker module is loaded.

Set irssi to beep ON for EVERYTHING to test if it works:

/set beep_msg_level ALL
/set bell_beeps ON

Tell screen to allow audible beeps with ^a^g. If you are using a local screen and screen on the remote (like I do), you need to tell the remote screen to also use audibles. Do this via the screen meta key 'a': ^aa^g. Toggles these multiple times to switch between visual and audible bells.

/msg nickserv help to hear if it works. Change the bell to clang on highlights only:

/set beep_msg_level HILIGHT
share|improve this answer

You need to add/edit your $HOME/.screenrc to include:

VBELL OFF

And/or disable it in a running instance with C-a C-g

The default /etc/screenrc in newer Debian sets VBELL ON for some reason.

Read more at https://www.gnu.org/software/screen/manual/screen.html#Bell

share|improve this answer
1  
please add more details to your answer :) – Kunal May 12 '15 at 9:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .