Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've read several of the other questions here and other pages on the web, but so far nothing I've tried has worked.

The video I'm trying to cache for offline viewing is this lecture:

http://stanford-online.stanford.edu/courses/ee380/120118-ee380-300.asx

I've tried:

  • using VLC to Stream to a file
    • if I disable transcoding, the resulting file is always 44KB.
    • if I enable transcoding, the resulting file is not playable! (Despite being ID'd as a MPEG4 by file)
  • using mplayer -dumpstream (also tried on the .wmv URL contained within the .asx)
    • I just get a bunch of "Stream not seekable! Stream not seekable! Stream dump complete."

I'm looking for a way to do this from the command line.

Totem has no problem just playing the stream, so I assume a way to dump the stream to a file is not out of reach, but I can't figure it out.

Anybody else able to record this? Thanks in advance.

Update: I was wrong on one data point - if I enable transcoding in VLC, the resulting file is playable (just have to wait for the whole thing to complete - it was the partial recording that was not playable). However, I'm still interested in a command-line approach to this problem, so that I can batch up many lectures.

share|improve this question
add comment

1 Answer

There's one particular cli software that gets flash videos https://code.google.com/p/get-flash-videos/ but it doesn't work with Stanford's site & asx

Maybe you could ask for support on the https://code.google.com/p/get-flash-videos/issues/list

Moreover, I tried Firefox's FlashGot & it was able to grab a .wmv link but that didn't work; the file was 187KB.

In case you find a solution, please write back.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.