Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have built an intranet for my company, but when I access the site using an alias (DrewNett) so of the styling in IE is incorrect. It's only in IE, and the source is exactly the same and when I go do the site using the FQD.

Is there any kind of issues with IE (silly question, I konw!) that may be causing this?

Also, does anybody have so ideas for trouble shooting, as I'm kind of stumped.

It's IE8 that is being used.

Answer - This was happening because IE8 was automatically displaying the site in Compatibility View because it was picking it up as an Intranet site. To stop this, in IE, go 'Tools -> Compatibility Veiw Settings', and then uncheck 'Display intranet site in Compatibility View'.

Thanks.

share|improve this question
    
Maybe the CSS references an image file by full URL (maybe spacer.gif) and IE treats it like XSS or something equally weird. –  Oliver Salzburg Feb 23 '12 at 10:30
    
@OliverSalzburg - No images in affected areas. The site is Wordpress, so all URL's point to the correct place any way because I always use there functions for making links, etc. It's really odd as very little is affected, so clearly the CSS is being accessed. –  David Gard Feb 23 '12 at 10:55
    
Given this issue is primarily a visual one, some screenshots might help. Hard to make any assumptions. –  Oliver Salzburg Feb 23 '12 at 11:09
1  
Ok, so it's because the site is being forced in to 'compatibility mode', but without the option to turn it off. Screenshots - will sort some and post a link shortly. –  David Gard Feb 23 '12 at 11:31
1  
...And I've sorted it - In IE, go 'Tools -> Compatibility Veiw Settings', and then uncheck 'Display intranet site in Compatibility View'. –  David Gard Feb 23 '12 at 11:44
show 2 more comments

1 Answer 1

up vote 2 down vote accepted

This was happening because IE8 was automatically displaying the site in Compatibility View because it was picking it up as an Intranet site. To stop this, in IE, go 'Tools -> Compatibility Veiw Settings', and then uncheck 'Display intranet site in Compatibility View'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.