Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I believe this is a very strange problem, but i just switched back to PC from Mac after nearly 20 years so I'm certainly no expert with Windows 7 yet.

My new computer has a Gigabyte HD 6970 GPU connected to a Dell Ultrasharp U3011 monitor (2560 x 1600) over DisplayPort.

Whenever I have windows open on screen, which are not maximized, turning off the screen will reduce the sizes of the windows and push them to the top left corner of the screen, as seen when turning back on the monitor. Of interest, windows reduce to 1022 x 726 pixels (??) but if a non-maximized is already positioned near the top left of the screen within the bounds of 1022 x 726 the window will remain unaffected.

How can I fix this annoying problem?

[EDIT] Since posting this question i've discovered that sometimes i receive the following alert if i turn off the monitor before the computer powers down into sleep mode.

enter image description here

share|improve this question

4 Answers 4

up vote 2 down vote accepted

There is a KB Article on this: http://support.microsoft.com/kb/2625567

No satisfyable workaround though.

share|improve this answer
    
thanks! i'm glad to know it's a known issue. this is the first PC i built and though i might have done something wrong. i wonder if it's possible to force/hack the native resolution in Windows 7 to 2560 x 1600 instead of 1024x768. that would solve the problem. –  TheDarkIn1978 Oct 12 '12 at 3:28

Since I connected my single 2560x1440 monitor via DP to onboard Intel HD Graphics port (only 1920x1080 max. over DVI), I always had this problem. Updating any drivers did not change anything.

Once I logged into UVNC remote desktop client, with monitor off and virtual 1024x768 desktop present, went to "Screen resolution" setup and tried maximum allowed there, around ~2000x1500. Now on real monitor all windows seem to stay where they were left.

Hope it helps someone.

share|improve this answer

Sounds to me like 'Windows' is not moving the -windows- err yeah, it's adjusting the screen/monitor resolution (desktop res.) and therefore the -window- which was in the "middle" of the screen by X-Y coordinate is now sitting top corner as the x-y is now different (get my drift)

I would check your resolution profile and save the profile when you set the display settings you wish; best if you use your -Graphics- provider UI/settings ie nVidea or Radion as you can customize more and saving a profile is generally more hard (read hard-coded or hard-set as in set in stone not soft) and less likely windows will overide; however even if you choose windows ie "Display Properties" and save your settings as "My Current Theme" or something therin you will see if the display changes wether or not 'Windows' has changed your Theme or Profile or just some settings it's self.

These steps should atleast help you trouble shoot some more to get closer to finder and answer and resolving it; could just be you have let it default without creating any settings and each time you shut off the monitor and back on the monitor says hello windows I prefer these settings as my Native Resolution and Windows says ok my user doesn't care so that works for me I'll just move somethings around here for you!

Hope that helps, Good luck!

share|improve this answer
    
Thanks for the reply. The settings in both Windows and AMD Catalyst Control Center contain the correct resolution. Also, since posting this question i've noticed an alert dialogue window whenever this problem occurs (see edited question). –  TheDarkIn1978 Mar 3 '12 at 20:48

My first instinct would be to try DVI, but I have plenty of cables lying around, so it's easy for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.