Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My problem is similar to the following question: How can I prevent Windows from disabling Aero?

I did not have enough rep to post a comment, but my question is somewhat different anyways.

It is different because of my setup and when the problem occurs. I have 8 gb ram. I use an HD 6990 to run a 30 inch panel. I also have two side panels hooked into the intel hd 3000 available from my processor. The side panels are 1920x1080 and the main monitor is 2560x1600.

Whenever I use one of the side panels, Windows 7 "detects slow performance" and disables aero. This occurs under just about any usage... even web browsing using firefox if flash is playing on the screen. However it is incorrectly determining slow performance. Task manager typically reports 27-33% physical memory usage (over 5 gb still available) when this happens. I checked and the intel graphics manager reports that it is using 112 mb of memory. It also reports that it has up to 3736 MB available. I know that it shares system memory but there is over 5 gb unused.

Is there any way to disable this obnoxious "feature"? I like aero and I don't ever want it to turn off. Is it possible to tell aero which graphics card to check for performance metrics? I am not interested in the speed of my side panels... otherwise I would hook them up to my primary graphics card. But it seems like a bug with aero since the intel driver is reporting 3 gigs of unused graphics memory available.

share|improve this question
    
Yes, Windows 7 64bit. My main display is connected via dvi to the 6990. The side panels are connected to the motherboard video outputs. My first side panel is connected via a dvi to hdmi cable. The second side panel is connected via a dvi to mini display port adapter (active adapter). –  user319862 Feb 24 '12 at 18:43
    
Oh... I said in my question that I was using a HD 6990 (dual ATI card) and Intel 3000 graphics (integrated into the i5-2500k) –  user319862 Feb 24 '12 at 19:05
1  
You could get an additional cheap card for one side panel and hook up the other side panel to the internal Intel HD 3000. It could improve the performance by not overloading the internal HD 3000 with two side panels to take care of. Just a suggestion. Btw, Crossfiring or SLI is not required for this. –  ADTC Feb 24 '12 at 19:18
    
@ADTC: That isn't a very good suggestion and it doesn't answer my question. You are also just reposting that comment from below. I don't think web browsing is "overloading" the intel hd 3000 chip either. –  user319862 Feb 24 '12 at 19:25
    
I'm sorry, yea it's not a direct answer to your question. Just a suggestion to boost performance. But Windows does think the web browsing (or even just drawing two extra desktops on one card) is overloading the HD 3000. It will only shut off Aero if the hardware can't handle it. –  ADTC Feb 24 '12 at 19:33
show 1 more comment

3 Answers

up vote 3 down vote accepted

I'm guessing you almost always have a browser open, like a lot of folks I know. I've seen this problem in both Internet Explorer and Firefox when running a browser on a display attached to a secondary GPU. The fix for that is to disable hardware acceleration in the browser - it doesn't always play nicely with DWM for some reason. (I seriously doubt you'll see any performance hit as a result of this).

It's possible there are other things going on, but some idea of what's ALWAYS running would be helpful to pin it down.

share|improve this answer
    
I'd also note that the 'slow performance' is not really incorrect. That's not based on system performance as a whole, but PURELY on metrics within DWM itself. DWM might be running slowly even though everything else on the system is okay, but Aero doesn't care about anything other than DWM. –  Shinrai Feb 24 '12 at 16:28
1  
Its also worthy to note that System memory throughput and VRAM throughput are worlds apart. –  Paperlantern Feb 24 '12 at 17:09
1  
I can't upvote your answer because I do not have enough reputation. Disabling hardware acceleration in firefox allows me to use firefox on the secondary monitor without making windows swap to basic mode. I am going to wait for a little while to mark this as accepted in case someone has a provides solution that works for everything. –  user319862 Feb 24 '12 at 19:02
    
Got enough rep to upvote =) –  user319862 Feb 24 '12 at 19:10
2  
For what it's worth, I've bugged this in the past as well, but I really suspect it's Microsoft's problem so I don't know that there's much they can do. ;_; I suspect it will be fixed for Windows 8 though. It's very specifically a problem with DWM; you can see its usage and handles spike right before this happens, and it won't always release them properly either. –  Shinrai Feb 24 '12 at 20:13
show 3 more comments

There's a problem with Displayport in combination with Aero. Try Windows Aero without the displayport (DVI > Displayport adapter should do the trick). That did work for me at least.

share|improve this answer
add comment

Have you tried forcing Windows to have Aero enabled?

  1. Right-click Computer in the Start Menu > Properties
  2. Advanced System Settings on left
  3. Settings button in the Performance section (the one at the top)
  4. Choose Adjust for best appearance (You can also choose Custom and select the options you want in the list below. The Aero option is a combination of desktop composition, transparent glass and visual styles if I'm not wrong.)
  5. OK > OK.
share|improve this answer
    
This won't actually keep this from happening. See, for example, this answer. If DWM can't handle the load, Windows will ALWAYS disable it - the alternative is a complete UI meltdown, after all. That just lets you force it on very low-end systems where they don't recommend it for performance reasons, but it does function. –  Shinrai Feb 24 '12 at 18:34
    
You would probably need to get an additional card. (Try to get same model as existing card if it supports CrossFireX-like technology or SLI.) It's not enough to have loads of memory. Your GPU needs to be fast enough to handle the load. From what I know, internal graphics (built in motherboard, using main processor) is usually not good enough. [When I built a desktop, I didn't mind everything else being on motherboard, but I went for a graphics card without a second thought. When I tested the internal graphics out of curiosity, it sucked bad!] –  ADTC Feb 24 '12 at 18:40
    
Intel HD 3000 should be more than adequate to the load in the example given. –  Shinrai Feb 24 '12 at 18:58
    
Yes I have done this. It doesn't work. I do not need to SLI my graphics card for this... The HD 6990 is two 6970s to begin with. The point is that I am not stressing the integrated graphics. –  user319862 Feb 24 '12 at 19:09
    
But thank you for the suggestion –  user319862 Feb 24 '12 at 19:09
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.