Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm usually on a PC, but recently, I've decided to give OS X a go (at work anyway). I don't have too many complaints. There is one, however, that is driving me up a wall.

Home and End don't seem to work right. What's up with that? I'm very used to Home sending the cursor to the beginning of a line, End sending it to the end of a line, Shift+Home selecting everything to the left of the cursor while sending the cursor to the beginning of the line, and Shift+End selecting everything to the right of the cursor while sending the cursor to the end of the line.

I'm rocking Snow Leopard, and I have KeyRemap4MacBook. I try not to use it too much (after all, part of the reason I'm using OS X is to learn it), but this is one feature that I simply cannot live without. The only two things I have enabled on KeyRemap4MacBook are

  1. Use PC Style Home/End, and
  2. Use PC Style PageUp/PageDown.

Home and End still don't work for most apps, and Shift+Home and Shift+End don't work either.

Is there any way I can get those working?

share|improve this question
up vote 2 down vote accepted

If you want to learn the OS X way, move to the beginning of the line with + and move to the end of the line with +. Combine with Shift to select text on the way.

share|improve this answer
Is there any particular reason that this doesn't work with Right Shift? Works fine with Left Shift though. Alright, I'll force myself to learn. Thanks! – Cody S Feb 25 '12 at 0:14
@CodyS It works for me with any combination of left and right Command and Shift keys, so I don't know what the problem is. – William Jackson Feb 27 '12 at 2:44

You can set your key behaviour the way you like by install this KeyRemap4MacBook.

Go to the app's Misc & uninstall tab, click private.xml and replace its contents with this

<?xml version="1.0"?>
    <name>PC Home and End</name>
    <identifier>PC style</identifier>
  KeyCode::CURSOR_LEFT, ModifierFlag::COMMAND_L  
  KeyCode::CURSOR_RIGHT, ModifierFlag::COMMAND_L  

then go change keys tab click ReloadXml on top right and tick the PC Home and End in the remapping block.

Finally, you have the PC style Home and End working.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.