Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever i use my middle mouse button to scroll through a web page (any web page) the screen starts tearing.

Additional info

  • This does not happen in any other browser.
  • I have latest graphic card driver so the problem is not in that.
  • I have latest firefox version (10.0.2)
  • I think the problem might have started when i updated firefox but I'm not 100% sure about that

Things i tried to do to fix the issue:

  • I tried closing all windows other than Firefox
  • I tried disabling smooth scrolling in Firefox preferences
  • I tried switching hardware acceleration on or off
  • I cleaned all cookies,cache,history and things like that

I tried to use "Restart with add-ons disabled" to enter safe mode and then i had no problems at all (there is no screen tearing when using middle mouse button to scroll up)

I then tried to run firefox normaly and disable all add-ons one by one individualy (extensions and theme) thinking that one of the add-ons was causing that problem,but even with all of them manually disabled the problem was still happening.

So does anyone know what might be causing the problem and how to fix it?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Problem was in newest ATI graphic card driver.

If anyone else gets this problem after updating their graphic card driver this is how to fix it:

For Windows XP:

  1. Go to control panel and double click on System
  2. Select Hardware tab
  3. Then click on Device manager and find Display Adapters
  4. Right click on your graphic card adapter and click on Properties
  5. Go to Driver tab use click on Rollback driver
  6. Chose to restart your PC and that's it , problem solved

That will rollback your graphic card driver to previous version and fix the above mentioned problem with Firefox.

EDIT: Seems to be somewhat fixed with the latest drivers. Still happens on occasion but rarely. If however you disable hardware acceleration in firefox and then restart the browser it will be fixed completely.

share|improve this answer
1  
I'm seeing this problem as well, but with an nVidia display. Sounds like more Firefox problems to me. Rolling back a display driver to fix a problem in an increasingly-buggy (and replaceable) browser is not really a solution for me. –  boot13 Jun 24 '12 at 13:51

I assume this is a memory issue though probably it happens when you got a lot of tabs open.Try these:

  • Try closing all windows other than Firefox.

  • Try disabling smooth scrolling in Firefox preferences.

  • Turn hardware acceleration on or off.

Hope this helps.

share|improve this answer
1  
I already did all of that before and nothing changed.And the amount of tabs i have open doesn't matter because it happens even when i have only 1 tab open.This issue started happening like 2 days ago,and i can't get to the bottom of it. –  ChrisHateZ Feb 25 '12 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.